Free Support Forum - aspose.com

BindHTMLFromUrl and <UL> double items

I am getting a blank line with a bullet whenever I use the BindHTMLFromUrl on a page that has an unordered list

    .


    Here is my HTML file:




    Untitled Page



    TEST TITLE


    • test item 1

    • test item 2

    • test item 3







    And here is the PDF code I call:

    Dim pdf1 As New Aspose.Pdf.Pdf

    pdf1.BindHTMLFromUrl(URL)

    pdf1.Save(“c:\test.pdf”)

    I have attached the PDF file that is generated. I am using 3.2 (I just upgraded to this).

    Thanks in advance for your help.


The error is confirmed in my testing. Our developers will find out reasons and reply to you soon.

Is there any update on this problem? My client would like to go live by Nov 15…

Please download hotfix 3.2.1.0.

I’m now getting the follwoing exception:

System.Xml.Xsl.XsltException was unhandled
LineNumber=0
LinePosition=0
Message="‘DeEntitize()’ is an unknown XSLT function."
Source=“System.Data.SqlXml”
StackTrace:
at System.Xml.Xsl.XsltOld.XsltCompileContext.ResolveFunction(String prefix, String name, XPathResultType[] argTypes)
at MS.Internal.Xml.XPath.FunctionQuery.SetXsltContext(XsltContext context)
at System.Xml.Xsl.XsltOld.Processor.GetValueQuery(Int32 key, XsltCompileContext context)
at System.Xml.Xsl.XsltOld.Processor.ValueOf(ActionFrame context, Int32 key)
at System.Xml.Xsl.XsltOld.ValueOfAction.Execute(Processor processor, ActionFrame frame)
at System.Xml.Xsl.XsltOld.ActionFrame.Execute(Processor processor)
at System.Xml.Xsl.XsltOld.Processor.Execute()
at System.Xml.Xsl.XsltOld.Processor.Execute(Stream stream)
at System.Xml.Xsl.XslTransform.Transform(XPathNavigator input, XsltArgumentList args, Stream output, XmlResolver resolver)
at System.Xml.Xsl.XslTransform.Transform(IXPathNavigable input, XsltArgumentList args, Stream output, XmlResolver resolver)
at Aspose.Pdf.HTML.⇔.Ժ(Stream Կ)
at Aspose.Pdf.Pdf.Ժ(Stream Կ, HtmlInfo Լ, Boolean Խ, String Ծ)
at Aspose.Pdf.Pdf.BindHTMLFromUrl(String url)
at MODACategoryImport.Module1.PrintFromURL() in d:\martron\DOTNET\MODACategoryImport\MODACategoryImport\Module1.vb:line 72
at MODACategoryImport.Module1.Main() in d:\martron\DOTNET\MODACategoryImport\MODACategoryImport\Module1.vb:line 264
at System.AppDomain.nExecuteAssembly(Assembly assembly, String[] args)
at System.AppDomain.ExecuteAssembly(String assemblyFile, Evidence assemblySecurity, String[] args)
at Microsoft.VisualStudio.HostingProcess.HostProc.RunUsersAssembly()
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()

I’m using the new hotfix 3.2.1.0



Hi,

I can not reproduce the reported exception by Aspose.PDF hotfix 3.2.1.0.

You could just build a VB project with the simple testing code to validate if the hotfix gets worked.

[simple testing code]

Dim pdf1 As New Aspose.Pdf.Pdf

Dim URL As String = "E:\NeedToTest\PDF\11.07\test.html"

pdf1.BindHTMLFromUrl(URL)

pdf1.Save("E:\NeedToTest\PDF\11.07\testvb.pdf")

I attached the generated correct result for comparison.

Kevin,

You are correct. It worked perfect…in 1.1. When I tried to run it in 2.0, the error is still there. I should have been more specific.

Sorry about that.

This problem is caused by obfuscator and we will try to resolve it ASAP. As a workaround you can use the 1.1 version of Aspose.Pdf in .Net 2.0. If you are not using 64-bit windows, they have no difference.

This bug has been fixed. It will be published in next hotfix. I can attach the dll here if you want.