Free Support Forum - aspose.com

Blank first page of pdf document on Windows Phone 8

Dear Aspose, we used Aspose 7.9.0 to create a pdf file from xml. I works perfectly on all readers and devices, except for Windows Phone 8, where the first page is blank. The strange thing is that if we remove a specific image tag, the first page will show up, but if we reposition the other image tags the first page will go blank. Looking forward for your support.

The xml document is attached to this post.

Hi there,


Thanks for your inquiry. I am preparing the required platform
to simulate the environment as of yours. As soon as everything is setup, I will
test the issue at my end and provide you more information accordingly.

Meanwhile, can you please confirm you are getting issue with all the images or some specific image? If issue relates with some specific images then please share the images referred in XML file.

Sorry for the inconvenience faced.

Best Regards,

Hi there,

Thank you for your reply. Well, I think that the problem is with the positioning of the images. In the xml there is one image which is used two times, if I remove the first occurrence then the first page of the pdf is visible and if I reposition anywhere the second occurrence, the first page is blank again.

Hi,


I have tested the scenario where I have first converted the XML file to PDF format using Aspose.Pdf for .NWT in Visual Studio 2010 over Windows 7 (X64) and then have tried viewing the PDF document in PDF Reader 1.1.4785.5817 by Microsoft Corporation over Windows Phone 8.0 and as per my observations, both pages are properly being displayed.

I have also tried viewing the PDF document over Windows 8 (X64) and Windows 7 (X64) using Adobe Reader and I am unable to notice any issue. Can you please try viewing the attached document at your end.