Free Support Forum - aspose.com

Blank first page with Evaluation text only

Hi,

I'm using the evaluation version of aspose.words ver 9.1 and creating pdf from htm templates. The first page is coming back as blank only with the following text "Evaluation Only. Created with Aspose.Words. Copyright 2003-2010 Aspose Pty Ltd."

I want to know if this is a normal action for ad evaluation version and once we move on actually purchasing the aspose.words then this first blank page will go away.

If that is not the case then kindly let me know whats the fix for this issue.

Regards,

Khurram Durrani

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. If you would like to test Aspose.Words without the evaluation version limitations, you can request a 30-day Temporary License. Please refer to

http://www.aspose.com/corporate/purchase/faqs/temporary-license.aspx

If the license applying does not help you, please attach your document here for testing.

Best regards,

Hi,

Thanks for your reply.

I actually just want to know that if its normal to have the first page in aspose.words evaluation version as only having the content "Evaluation Only. Created with Aspose.Words. Copyright 2003-2010 Aspose Pty Ltd."

and our content starts from the second page.

Just wondering if you can kindly confirm that this is how the aspose.words evaluation version behaves.

Thanks.

Hi Khurram,

Thanks for this additional information.

You are correct, it's not normal to have the first page blank. Normally the evaluation message appears at the top of the first page and the content directly below it. Could you please attach your template here for testing and we will take a closer look.

Thanks,

Hi,

Thanks for your prompt reply. I've actually investigated this issue a bit more and the issue is the same even after applying the license.

So at first with the evaluation version we had the first page of the generated pdf document showing the Evaluation warning only and the second page showing the Evaluation warning along with our contents. Now, after applying the license we have gotten rid of the evaluation content but the first pag is just blank now and our contents starting from the second page.

Is there anything that i have missed?

Thanks.

Hi Khurram and Adam,

Our issue seems to be that after placing the license in the right place and registering it using the provided code, we're still getting a first blank page (with no warnings in it). I'm quite positive that the application is finding the license and doesn't throw any exceptions.

Adam, you gave me a couple of pointers yesterday in our Live chat conversation. We seem to have developed and tested against Aspose.Words.dll version 9.1.0.0. Product Version 2010.05.14

Our license file is version 2.2. I tried using the latest Aspose.Words.dll (version 9.2.0.0 ) but that doesn't compile with our code. Some of the references we've been using don't resolve in 9.2.0.0.

Could you please confirm:

  1. Are licenses bound to a specific assembley version ?
  2. Has anyone experienced this issue before ( a blank page added to the document ?)

Thanks,

Shuku.

Hi Shuku, Khurram

Thanks for the additional information.

Yes, there were a few breaking changes to the API starting in version 9.2. The details of how to change your code can be found in the migration article here.

Regarding your questions:

  1. That is a good question. I have seen a few instances of evaluation licenses not working with older versions. I will look into this and get back to you.
  2. I was unable to find any open issues similar to to your problem at the moment.

If you are able to attach your template here then I can take a closer look and provide you with more information. Only staff members can download your attachments in this thread so your documents are kept private.

Thanks,

Hi Adam,

We're in the testing phase and we can't risk using the new version of the API's.

Did you manage to find out whether this could actually cause any issues. In which case could you generate a new license file for us to comply with the older version of the API's ?

As for providing you with the source code, it would be extremely difficult to do so, but I can provide you with a sample of the markup that is used to generate the sample PDF, and the DLL version is 9.1.0.0.

The markup goes through minor text replacements, but even if we cancel the text modifications we still get the first blank page.

If you could test this with our DLL version and license please, that'd be much appreciated.

Cheers,

Shuku.

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. May I ask you what is the purpose of evaluating old versions of Aspose.Words? If you will satisfied with an evaluation and decide to purchase Aspose.Words, you will buy the latest version and you will be compelled to change your code to use new API.

If you would like to check your license on your side, you can try creating simple console application to check whether the license works. For example see the following code:

//Set license

Aspose.Words.License lic = new Aspose.Words.License();

lic.SetLicense("Aspose.Words.lic");

//Create simple document for testing

Document doc = new Document();

DocumentBuilder builder = new DocumentBuilder(doc);

builder.Write("Hello world");

doc.Save(@"C:\Temp\out.doc");

Best regards.

Hi Shuku,

Thanks for this additional information.

I have tested your documents using Aspose.Words Version 9.1 but was unable to reproduce any issue with an blank page being inserted at the beginning of the document. Can you please run a simple test like the one Alexey has set out above and see if this issue still occurs.

Also I have double checked and it seems evaluation licenses follow the same behaviour as the full licences in which they will only work with the latest version and not previous versions.

Most likely the best way for you to solve this issue with the licensing is to simply upgrade to the latest version as Alexey suggested. The changes to the API in the new versions is very minor and only a few members are affected. It is very easy to change those members in your code and is detailed fully in the migration article here.

Hi guys,

Thanks for your suggestions. I tried running your code snippet which obviously works fine. The problem seem to arise when we start with a HTML as an input.

I'm attaching a prototype application we have which reads a HTML ( included ) and uses a word template ( included) to generate a word doc, using either aspose or word automation. The interface is quite intuitive, so please feel free to have a play around and see whether you can reproduce the problem.

The reason why we haven't moved to 9.2 yet, is because all our testing has been against 9.1 and we don't want to be taken by surprise towards the delivery, as well as all the re-work we need to do, but if 9.2 solves these issues we might consider it.

Cheers,

Shuku.

Hi there,

Thank you for this additional information and the detailed project. I have had a full test of your application but was unable to reproduce the issue with the page break using Aspose.Words 9.1, regardless of having set the license or not.

Could you please provide some further details about how to reproduce the issue and I will have another look. Also could you post a screenshot of the issue at hand as it may help.

I have attached the output produced by Aspose.Words in the application.

Also please note with this project, when you migrate to the API in Aspose.Words 9.2, the only changes you will need to make is a bit of code relating to the ReplaceEvaluator event.

Thanks,