We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Bookmark/Merge and word 2007 documents

We have the Aspose.Words for Java 1.4, latest patch for Word 2007

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

We are struggling with a weird issue... We have word files stored on our server - that our system uses your tool to "bookmark"/merge data into - then send the file down to the client's pc to save/open.

We are noticing that form fields don’t work with Office 2007.

We can’t figure out what the heck’s going on except one little clue makes me think that the template function is not compatible with the new Office 2007 forms elements, and maybe some other aspects of the new file types. We tried adding a new checkbox and saw that there was a “Legacy Forms” group of form controls available in Word, and then a separate group of the kind that are used in Marie’s document, called “ActiveX Controls”. The ActiveX controls look and feel more like VisualBasic-type elements.

We added a “legacy” checkbox and protected the document for forms, uploaded the template to Totality and generated a document from it. The ActiveX checkboxes are all dead, but the “legacy” one worked like a charm – can check it and uncheck it. Pretty weird.

We tried adding a new embedded spreadsheet and got the same behavior as the client’s – just can’t open it.

But the bookmarks seemed to work fine.

Any suggestions ????

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for you request. Could you please attach sample document here for testing? I will check the issue and provide you more information.

Best regards.

Here is a sample file, we can’t get all the fields to work.

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. I managed to reproduce the problem on my side. You will be notified as soon as it is resolved.

As a workaround you can just use formfields instead of ActiveX controls.

Best regards.

Alexey,

Can you please update us if this issue has been resolved, and what version of Aspose.Words includes this patch.

Thank you,

Konstantine

Hi Konstantine,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. Unfortunately, the issue is still unresolved. We will let you know once there is some progress with this issue. My apologizes for inconvenience.

Best regards.