We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Bookmark.Remove very slow in the Aspose.Version 18.6

Hello,
we have a document 717 bookmarks and we want to remove the bookmarks at the end of a process.
We recognized that there is a huge difference between the performance Aspose.Words.Bookmark.Remove had in the version 17.1 and it has in the new version 18.6
In Version 17.1 it took about 5 seconds to remove 717 bookmarks.
In Version 18.6 it takes about 60 seconds to remove 717 bookmars.
In Version 17.1 it removes about 140 bookmarks in a second.
In Version 18.6 it removes just about 5 bookmarks in a second at the beginning and it gets better as the number of the remaining bookmarks becomes smaller (up to 55 bookmarks). There is a correlation between the number of bookmaks in the document and the removing speed of Aspose.Word.Bookmark.Remove (see the attached picture)
Diagram.png (29.1 KB)

Why is it like this? How can this problem be solved? It is very critical and would prevent us using the new version.

@stanlife,

Thanks for your inquiry. To ensure a timely and accurate response, please attach the following resources here for testing:

  • Your input Word document.
  • Please create a standalone console application (source code without compilation errors) that helps us to reproduce your problem on our end and attach it here for testing.

As soon as you get these pieces of information ready, we’ll start investigation into your issue and provide you more information. Thanks for your cooperation.

PS: To attach these resources, please zip and upload them.

Here are the two standalone console applications. One for the quick one with the old Aspose version 17.1 and a second console application with the new but slow Aspose version 18.6.
Each application outputs the performance of removing bookmark in the debug window. By reading the timestamp values you will consider the big difference of the perfornance of the applications.
The Word document is in the bin folder. You have just to insert your Apsose.Words.lic in the folder for each application.
RemoveBookmarks_Aspose17_1.zip (7.3 MB)
RemoveBookmarks_Aspose18_6.zip (5.7 MB)

@stanlife,

Thanks for the details. We tested the scenario and have managed to reproduce the same problem on our end. For the sake of correction, we have logged this problem in our issue tracking system. The ID of this issue is WORDSNET-17300. We will further look into the details of this problem and will keep you updated on the status of correction. We apologize for your inconvenience.

Will you send any updates in this forum in this thread? Or have I to look anywhere else?

@stanlife,

This thread has been linked to WORDSNET-17300 and reflects the current status of this issue. We will also inform you via this thread as soon as this issue is resolved.

Hello, I wanted to ask what the status of the ticket is. Here it is stated “In Review”. What exactly does that mean? When could I expect a solution or a reply for this problem?

@stanlife,

Thanks for your inquiry. Hopefully, the fix of this issue will be available in September 2018 release. We will inform you via this forum thread once it is published.

I wanted to ask about the latest status of this ticket. Has that been solved? Does it come with the next release? When exactly is the next release and where can I download it?

@stanlife,

Thanks for your inquiry. This issue has been resolved and its fix will be available in next version of Aspose.Words i.e. 18.9. Hopefully, this release will be available at the end of this week.

The issues you have found earlier (filed as WORDSNET-17300) have been fixed in this Aspose.Words for .NET 18.9 update and this Aspose.Words for Java 18.9 update.