We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

BouncyCastle BCprov.jar

Hi there,


could you please explain for what bcprov146.jar is needed (at least for which options within aspose.cell)? We are going to migrate our code to BC 1.53 and would have a class version conflict so…

Regards,

Steffen

Hi,


Thanks for your query.

Well, the bcprov-jdk16-146.jar (http://www.bouncycastle.org/java.html) file is used only for AES encryption supported by MS Excel 2010 or greater versions.

Thank you.

OK, is this the “password protection” option? Are there any plans to migrate to 1.53 or 1.54?

Hi,


Yes, this is password protected or encrypting option.

Regarding our plans to migrate to 1.54, we will discuss with the concerned developer from product team, we may get back to you in the next week.

Thank you.