Free Support Forum - aspose.com

Bug formular - Very Urgent

I thing there is a problem with the formular property.
We have a german EXCEL Version. Change WENN to IF if you try.

When I set the property to the following…
=WENN(K6>70000;3;WENN(K6>50000;2;WENN(K6>20000;1Wink))

Then in EXCEL you will find the following Forumlar
=WENN(K6>‘70000;3;WENN’(K6>‘50000;2;WENN’(K6>‘20000;1;’())))

and the following formulars contains…
=K7 K7 K7>‘20000;1;’>‘50000;2;WENN’>‘70000;3;WENN’ WENN

but there was the same property settings

It’s very urgent cause we have to send the generate to our 750 supplierers over the world. Thanks for help.

I fixed this bug and upload the new hotfix. Please download it at http://www.aspose.com/Products/Aspose.Excel/Fixes/Aspose.Excel.zip.

If you still meet this problem, please verify if you deployed previous dll into GAC(Global Assembly Cache). If you had done it, even you removed the old dll, you program still referred to the previous version of Aspose.Excel.dll. Please remove it in your GAC, and add the new dll to GAC.

I have tried your new Version something has changed now the formular contains the following :

=WENN(K6>=‘70000;3;WENN’(K6>=‘50000;2;WENN’(K6>=‘20000;1;’())))
=WENN(K7>=‘70000;3;WENN’(K7>=‘50000;2;WENN’(K7>=‘20000;1;’())))

and so on, but it must be:
=WENN(K6>=70000;3;WENN(K6>=50000;2;WENN(K6>=20000;1Wink))
and so on.

Now I get much trouble, when we do not find any solution for this problem.
Should I better look for another Excel tool ?

Your tools are great but I get time Problems, for our project. The Sheets must leave today our house.

Sorry, I forgot to mention one thing: the delimiter in functions should be ',', not ';'.

So your formula should be:

=WENN(K6>=70000,3,WENN(K6>=50000,2,WENN(K6>=20000,1)))

Ok Thanks, now the formular seems to be OK but EXCEL now sets the field to #NAME. The Comment in Excel is unknown name but when I edit the field with no changes then it will work. What is that for ?

#NAME?

After Edit with no changes
=WENN(K6>=70000;3;WENN(K6>=50000;2;WENN(K6>=20000;1;0)))

And It will work.

What can I do to get it to run.

Another Problem occurs, when i send decimal values after the comma.
Such like this, “3,5” I also tried out “3.5” but nothing will work. It only comes the following:
=WENN(E192>=50000;35;WENN(E192>=35000;3;WENN(E192>=25000;25;WENN(E192>=15000;2;0))))

I’ve got a crisis with this formulars.
Sorry for my inconvienience

I don't know German. Does "wenn" mean "if" in English?

If yes. please set your formula as "=IF(K6>70000,3,IF(K6>50000,2,IF(K6>20000,1)))" or "=IF(K6>70000,3.5,IF(K6>50000,2,IF(K6>20000,1)))".

Aspose.Excel can only set English functions. Please check http://www.aspose.com/Products/Aspose.Excel/Api/Aspose.Excel.Cell.Formula.html.

Hi Laurence,

now it will work fine. But there is a little Problem with the decimal Point.

My code was:
=IF(E192>=50000;3.5;IF(E192>=35000;3;IF(E192>=25000;2.5;IF(E192>=15000;2;0))))

But I get in the the Sheet:
=IF(E192>=50000;35;IF(E192>=35000;3;IF(E192>=25000;25;IF(E192>=15000;2;0))))

Thanks for your realy great support and the quick help.

Please make sure it shows “35” or “3 5”. It works fine in my machine and I sent you an email.

Here is my temp solution to solve the problems for now:
We hope you will find a solution in the next hotfix.

Dim licenseFile As String = MapPath(“edit\License”) + "\Aspose.Excel.lic"
myExcel = New Excel(licenseFile, Me)
mySheet = myExcel.Worksheets(myExcel.Worksheets.Count - 1)

myExcel.Worksheets(0).Cells(“A1”).PutValue(Convert.ToDecimal(25621))
myExcel.Worksheets(0).Cells(“B1”).Formula = “=IF(A1>=50000,” & solvASPBug(3.5) & “,IF(A1>=35000,” & solvASPBug(3) & “,IF(A1>=25000,” & solvASPBug(2.5) & “,IF(A1>=15000,” & solvASPBug(2) & ",0))))"
myExcel.Worksheets(0).Cells(“C1”).Formula = “=(A1*B1)/100”

Dim myFile As String = "Test.xls"
myExcel.Save(myFile, SaveType.OpenInExcel, FileFormatType.Default, Response)
myExcel = Nothing

Private Function solvASPBug(ByVal pDecimal As Decimal) As String
000.000 = 3 Decimals behind the comma
Return “(” & CInt(Replace(Format(pDecimal, “000.000”), “,”, “”)) & "/1000)"
End Function