BUG! Save/Write removes all slide transitions

Hi,

i found a big bug in the Aspose Slides for .NET Product.

The behavior occurs in Version 7.6.0.0, so we renewed our subscription and updated to Version 7.9.0.0.

At first i thought that Slides.AddClone(slide) does not copy all transition Information. So i created them manually. But each time when i save the file all transitions are lost.

So i tried that as trivial as it could be… new c# Project solution, adding reference, including license and so on…

I open a PPTX File with slide transitions. (Automatic slide change after 10 seconds on each slide)

I save this PresentationEx that i just loaded with no Manipulation to a new Destination and all transitions are gone. Save and Write produce the same.

So it is not possible to save a pptx file with aspose slides without loosing all transitions.

That can not be serious. I Need a fix for this asap. I have not tested it with ppt files (97-2003) because that is no solution and no possible Workaround.

Kind regards

Steven Spyrka

In fact of that this “new message” site is corrupted in Chrome and Firefox i Need to use IE but there i can not upload a file. So here is the file that i use:
http://filex.mcon-mannheim.de/filex/zone/steven.spyrka/-2102445841v

Hi Steven Spyrka,


Thanks for sharing the details. What I have perceived from your query is that you have a presentation with slide transitions inside it. Once you open the presentation and save that using Aspose.Slides, the slide transitions effects are lost. I have tried to access the link that you have shared for downloading the sample presentation but have failed to find presentation there. Please share the sample input presentation with transitions along with used sample code and I will investigate that further on my end to help you out.

Many Thanks,

Hi Mudassir Fayyazv,

thank you for your fast Response.

I uploaded the File on my skydrive. http://sdrv.ms/1bdPedW

This is a simple code to reproduce the bug.

var license = new Aspose.Slides.License();

license.SetLicense(“Aspose.Slides.lic”);

Aspose.Slides.Pptx.PresentationEx p =

new Aspose.Slides.Pptx.PresentationEx(@“C:\master.pptx”, new Aspose.Slides.LoadOptions(Aspose.Slides.LoadFormat.Pptx));

p.Write(@“C:\master2.pptx”);

Best regards

Steven

Hi Steven,


I have worked with the presentation file shared by you and have been able to observe issue of missing transition effects in saved presentation. An issue with ID SLIDESNET-34717 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

We are sorry for your inconvenience,

Thank you for your Information. I hope there will be a fix very soon.

Hi Steven,

The issue has just been created in our issue tracking system and we will try our best to resolve the issue as soon as possible and share the good news with you.

Many Thanks,

The issues you have found earlier (filed as SLIDESNET-34717) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.