Free Support Forum - aspose.com

Bug with versions above 1.5.0.0?

Hi,

I get an error that looks like this:

System.IndexOutOfRangeException: Index was outside the bounds of the array. at dz.e(Int32 A_0) at d1.a(bx A_0, Int32 A_1, Int32[] A_2, Int32[] A_3, Int32 A_4) at d1.a(bx A_0, Int32 A_1, Int32[] A_2, Int32[] A_3, Int32 A_4) at d1.b(bx A_0) at bx.ap() at am.a(ax A_0, Pdf A_1) at Aspose.Pdf.Pdf.Save(String pdfFile) at AsposeTest1.WebForm1.DoPDF() in c:\inetpub\wwwroot\AsposeTest1\WebForm1.aspx.vb:line 55

This happened with versions 1.5.19.0 and 1.5.22.0. But an older version I had of 1.5.0.0 worked just fine with my XML file.

Here’s my code:
Dim pdf As New Pdf(“C:\Inetpub\wwwroot\AsposeTest1\bin\Aspose.Pdf.lic”)
pdf.BindXML(“C:\Development\Aspose\Template\badfile_test.xml”, Nothing)
pdf.Save(“C:\Development\Aspose\Template\PDF_Template.pdf”)

I’ve marked 2 cells at the end of the XML file with a red background (backgroundcolor=“red”). The text in those cells are ‘TOTAL FINANCE CHARGE’ and ‘122.32’, but if you set either of them to blank, the PDF gets generated just fine. The problem comes up when both of those cells are set to some non-blank text.

So I’m wondering what changed between 1.5.0.0 and 1.5.19.0 which would cause this?

The XML file is too big to paste in here, so in case you need to take a look at the XML, you can view it here: https://www.trumark.org/badfile_test.txt

Thank you in advance for your help,

Dear Kostik,

Thanks for your consideration.

Please download hot fix here.


Great, whatever you did in 1.5.23.0 fixed it!
Thanks for the timely support!