Bullets no longer showing with Aspose.Word 2.5.0.0


#1

Hi,

we have just tried migrating to Aspose.Word 2.5.0.0 after sticking with Aspose.Word 2.2.8.0 for a rather long time. After running our project, we have checked the resulting Word document and it seems that bullet points are no longer being displayed. The column on the right looks like its contents has been formatted for bullet lists, but no bullets show up.

If there’s anything else you need, please let me know

Regards

Kai


#2

Hi Kai,

Thank you for considering Aspose.

Please attach the original document, too. It would allow us to figure out the problem’s cause. If you use the document builder to create the document, post the fragment of your code instead.


#3

Dimitry,

thanks for taking care of this. Please find attached the template document and the code snippet that does most of the job creating the table.

Regards

Kai


#4

The problem lies in that you set the left indent of the paragraph to 0:

builder.ParagraphFormat.LeftIndent = 0;

Since the bullets are placed in a table cell, this makes them hide - they are just outside of the cell and therefore are truncated. So remove the lines used for setting the indent or set a positive value. Please note they occur in your code twice.


#5

Dimitry,

of course that’s it. This was just a leftover of what we’ve tried in order to make the document fully left align the bullets within the table cell.

When you open the attached sample (regenerated without ParagraphFormat.LeftIndent == 0), you will see that you are able to unindent each bullet point by one.

How would you try to achieve this in code?

Thanks

Regards

Kai


#6

This feature was already requested and this is what we are working on. The possibility of making the lists fully left aligned will be available later.

If the full left alignment is a requirement for you, what about simulating the list as a workaround in the meantime? It could be implemented like this:

builder.ParagraphFormat.FirstLineIndent = -15;
builder.ParagraphFormat.LeftIndent = 15;

for (int i = 0; i < 10; i++)
{
builder.Font.Name = “Symbol”;
builder.Write("\u00b7 ");
builder.Font.Name = “Helvetica”;
builder.Writeln(“Item” + i);
}


#7

Dimitry,

thanks for the suggestion. I might look into this alternative. It isn’t that important, just a cosmetic issue.

Regards

Kai