Free Support Forum - aspose.com

Cannot set XmpData of BMP image

Hello Team,

I have run into an unexpected issue using Aspose.Imaging library. I wanted to remove the metadata of a BMP image and as part of this process, I intended to set its XmpData property. However, after I had loaded the input file as an “Aspose.Imaging.Image” type, casted it to a “RasterCachedImage” and set its XmpData, the following exception occured: “The method or operation is not implemented”.

I have tried the same solution for JPEG, PNG, GIF and TIFF images and it worked. Also, according to the documentation, it should work for BMP as well.


OS: Ubuntu 18.04, Windows Server 2019 (tried on both, issue was the same)
DLL: Aspose.Imaging for .NET 20.12 (latest stable)
License: tried with licensed and unlicensed product as well, the issue was the same

I attached a simple (unlicensed) zipped app so that you can reproduce the issue. It contains a test file too, so you only have to load the solution file and run the project. It will print the error message to the console.

I would be grateful if you could help me with this issue. Looking forward to hearing from you soon!

All the best,
Tamas Boldizsar

cannot_set_xmpdata_of_bmp_image.zip (18.7 KB)

@tamas.boldizsar

I have created an issue with ID IMAGINGNET-4312 to further investigate and resolve the issue on our end. This thread has been linked with the issue so that you may be notified once the issue will be fixed.

@mudassir.fayyaz
Thank you very much!

@tamas.boldizsar

You are always welcome.

@tamas.boldizsar

We have internally verified the requirements and as per Adobe specification Bmp format does not support embedding XMP data. Please refer to this PDF link for your convenience.
Therefore, we can not support it and for future reference, we will raise more informative exception for this format.

@mudassir.fayyaz

Understood. Thank you for your effort!

@tamas.boldizsar

You are always welcome and please feel free to share if you have any thing else to discuss with us.