We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Can't figure out cause for NoClassDefFoundError: aspose/pdf/Paragraph

I can’t get any pages of my webapp to load (locally on Tomcat 7.0.2.6), due to this NoClassDefFound error. I’m at my wits end trying to figure out what the cause is, here is what I know:

My coworker has this project successfully running locally (on Tomcat) and on our development server (WebLogic).

I have done a fresh pulldown from svn so my code is exactly the same as his. I’ve verified that I have a shared library reference to Aspose (and that the required .jars are in there), and that weblogic.xml has an entry for it.

We saw this same error when initially deploying on WebLogic because the Aspose library was named incorrectly, but it ran fine locally on his Tomcat server.

I’ve tried cleaning and rebuilding the project to no effect.

As best as I can figure, it has to be either a Tomcat issue, or maybe an Eclipse setting.

Has anyone encountered a similar situation? Any ideas on what to try to resolve this?

@gracylayla,

I have observed the issue shared by you and like to share that the issue seems to be related to configuration on your end. I suggest you to please try disable jar validation for Aspose.Slides for Java on your end while using Tomcat and then try your sample code. This issue is not related to Aspose.Slides but related to configuration on your end.