We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Can't find Save overload that sends document to HttpResponse

I just installed Aspose.Words for .NET 9.3 and can't save/open the document to the browser. The documentation states there is an overload to do just this, but I don't see it in the dll.

public SaveOutputParameters Save(HttpResponse,string,ContentDisposition,SaveOptions);

When I had the 9.0 version of the Word API, the code was:

doc.Save(documentTitle, SaveFormat.Doc, SaveType.OpenInApplication, response);

When I tried to use the new Save overload above, it wasn't available. I checked the version of the dll and it is definitely 9.3.0. Is the documentation out of sync with the dll?


This message was posted using Page2Forum from Document.Save Method (HttpResponse, String, ContentDispositi... - Aspose.Words for .NET

Hi Malieka,

Thanks for your inquiry. The documentation is up to date and that method has the correct signature. You can find further examples in the migration article here.

If that does not help, can you please post your code here. Also please check what version of .NET you are using? If you have changed to .NET 3.5 then the HttpResponse object will be unavaliable.

Thanks,

Actually, I only updated the Aspose.Words dll. I was hoping it would resolve an issue I was having with merging child data.

I have been working in 4.0 all along. Here is the statement I was using previously:

doc.Save("test.doc", SaveFormat.Doc, SaveType.OpenInApplication, response);

...and it was working.

This is what I tried to change it to:

doc.Save(response, "test.doc", ContentDisposition.Attachment, null);

The error I am receiving is that No Overload takes 4 arguments.

Hi Malieka,

Thanks for this additional information. Could you please clarify what version of .NET you are using?

Could you please try using the .NET 2.0 framework and see if this error still occurs.

Thanks,

I can't downgrade the application to 2.0. There are a number of things I am using throughout the application that weren't introduced until after 2.0. I am using .NET 4.0

I don't even see the definition for the Save overload in the definition in the Object Browser.

Hi Malieka,

I think the issue you are experiencing is explained in this thread here.

Thanks,

Thanks for the reference. Now, I understand that you wanted me to downgrade the Aspose.Words.dll to .NET 2.0. That did the trick. I appreciate your assistance in resolving this issue.

Thanks,

Malieka