We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Can't Install Aspose.Words for Reporting Services and Can't Render 3+ Page Reports With License

We have attempted to run the msi installer for Aspose.Words for RS on serveral workstations running SQL Server 2008 with no success. I managed to get the Aspose.Words.RerportingServices.dll and install manually. However, I can not render reports with 3+ pages even though I successfully installed the license.

We want to purchase this product but I want to be confident that we can render reports of all sizes. Please assist.

Ken

Hi Ken,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. Do you see text like the following at the end of your reports?

This document was truncated here because it was created using Aspose.Words in Evaluation Mode.

In this case, you did not apply or improperly applied the license. If you want to test Aspose.Words for without the evaluation version limitations, you can request a 30-day Temporary License. Please refer to

http://www.aspose.com/corporate/purchase/faqs/temporary-license.aspx

If you already got a temporary license and successfully installed it, but still you see an evaluation watermark in your reports, please check the following points to resolve the problem:

1. Please, make sure that license is placed correctly. As described here:

http://www.aspose.com/documentation/ssrs-rendering-extensions/aspose.words-for-reporting-services/license-aspose-words-for-reporting-services.html

2. Try restarting IIS.

3. Make sure that license was created for Aspose.Words for Reporting Service. Just open your license file using NotePad and you should see the following tags.

Aspose.Words for Reporting Services

4. The license file should have name “Aspose.Words.Reporting.Services.lic”. Please make sure that your license has correct name.

Best regards.

Thanks for your reply Alexey. Unfortunately, we get no watermark or message indicating that we have improperly installed the license. It does appear that we have the temporary license correctly installed (LicenseVersion 2.2).

On some fairly complex reports (with multiple subreports and datasets) the report never renders when we attempt to export via any of the Aspose formats. We don't have this problem with the SSRS formats.

We also attempted to run the installation on 4 servers running SQL 2008 with no success, and had to install manually. We really like the clean html rendering format of the reports that we are able to export. I sure hope we can get this resolved because this could be a dynamo product for our company.

Thank you for your assistance with this case,

Ken Parker

Hi Ken,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. Could you please also attach your rdl report and rdl.data file here for testing? We will check the issue and provide you more information.

Best regards.

Hi Alexey.

Attached are the RDL files the parent report is sumcat13.rdl and the others are sub reports. We did discover an issue with another report that was return a null query. We removed the tablix object associated with the dataset populated from the null query and the Aspose rendering worked. We think this may be related to the hide attribute we set on a tablix bound to a null dataset. However, we didn't have this issue with the attached reports that can't render in some cases.

Please let me know if you desire additional information. We will continue researching on our end and let you know if we make any other useful discoveries.

Thanks again for your great support!

Ken Parker

Hi Ken,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. Your request has been logged in our defect database. The developer, who is responsible for Aspose.Words for Reporting Services will answer you shortly.

Best regards.

Hi Alexey,

I’m assisting Ken with this issue and I found that whenever we have a visibility condition for a row which is in nested group, Aspose.word is having a problem in rendering it.I think this may help you in narrowing down the cause for this problem.If you have any questions please feel free to contact me, I will be more than happy to assist you.

Thanks,
Shawn.

Hi Alexey,

Our Company is really interested in purchasing your ASPOSE Words for Reporting Services product . However, if your team is unable to resolve the rendering defect we discovered last month we will have to consider an alternative solution.


Please let me know if you anticipate finding a solution to this issue soon, or kindly recommend any other solution to satisfy our SSRS rendering requirement.


Thanks,
Shawn.

Hi Alexey,

We are really interested in purchasing your Product. However, if your team is unable to resolve the rendering defect we discovered last month we will have to consider an alternative solution.


Thanks,
Shawn.

Hi Shawn,

I am really sorry for delayed response and the missed posts. I am looking into your issue right at the moment, please expect a reply (hopefully a fix) in no more than 1-2 days.

Thanks.

Hi Shawn,

Could you please provide your rdl.data files as well or, if possible, your data source used to populate the report? I do need that to reproduce the issue.

Thanks.

Hello Dmitry,

I want to thank you for your quick response and your support with the Aspose RS rendering issue. I’m providing you with a report example that includes complex grouping that seems to produce the bad behavior (i.e. Hanging during rendering process). Also, please find the attached query logic and stored procedures which generate the data.

Ken already posted another one of our complex reports(rdl) that you might also choose to evaluate.

We would be happy to assist you in any way to expedite a quick resolution to this issue. Thanks again for all of your support and I look forward to hearing from you soon.

Sincerely,

Shawn.

Hello Dmitry,

I just want to follow up on the Aspose RS rendering issue. Please let me know if you where able to reproduce the bad behavior using our rdl ?.

Also, Can you please provide us a date when you anticipate this issue to be resolved.

As mentioned before we would be happy to assist you in any way to expedite a quick resolution to this issue.

Thanks,
Shawn.