We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Cell conditional formatting failing when cell.Value = 0


I am using Aspose.Cells v.7.4.2 and am having a problem with the rendered output of a worksheet with a number of conditional formatting rules used to control the color of the cell based upon the cell's value.

The conditional formatting worked fine except for the case when the cell value is set to Zero. Then it appears as though the rule engine is not engaged. If I open the spreadsheet in Excel and type in the Zero value, I get the red background as expected. However, when the cell value is set programmatically, the background does not change.

I have attached a zipped file containing the VB code snippet, source data file, spreadsheet and PDF of the rendered output.


Doug Kemp


Thanks for the sample code and template files.

After an initial test, I can notice the issue as you have mentioned. I have used a simple sample code with your file and found the issue as you pointed out.

Sample code:

Dim workbook As New Workbook("E:\test2\colored_labels.xlsx")
Dim worksheet As Worksheet = workbook.Worksheets(0)

Dim printOptions As New Aspose.Cells.Rendering.ImageOrPrintOptions()
printOptions.ImageFormat = ImageFormat.Png
Dim sr As New Aspose.Cells.Rendering.SheetRender(worksheet, printOptions)
sr.ToImage(0, "e:\test2\output.png")

I have logged a ticket with an id "CELLSNET-41639" for your issue. We will look into your issue soon.

Once we have any update on it, we will let you know here.

Thank you.

Do you have an ETA for a fix to the issue CELLSNET-41639? We have a customer waiting for this fix.

Thanks in advance,
Doug Kemp


I checked the status of your issue, it is still not resolved. I have logged your comments to attach with your issue “CELLSNET-41639” into our database. I have asked the concerned developer to share an eta or update on it, once we have any update on it, we will let you know here.

Thank you.


Thanks for your posting and using Aspose.Cells for .NET.

We have fixed the issue.

Please download and try this fix: Aspose.Cells for .NET v7.4.3.3 and let us know your feedback.


I have tested the fix you have provided and it has corrected the problem. I appreciate getting this version out of band with your monthly release cycle.

Many thanks,

Doug Kemp


Good to know that your issue is sorted out with the new fix.

Yes, as always our next official release (hopefully v7.5.0) of the product would include all the previous fixes and enhancements.

Thank you.