Free Support Forum - aspose.com

Cell corruption with using group:merge smart marker

Hi!

There is a problem with using “group:merge” smart marker ( Aspose.Cell 4.8.0) :


<o:p></o:p>

Code:

DataTable dt = new DataTable("Rows");

dt.Columns.Add(new DataColumn("field1", typeof(string)));

dt.Columns.Add(new DataColumn("field2", typeof(float)));

DataRow dr = dt.NewRow();

dr["field1"] = "test";

dr["field2"] = 69.03;

dt.Rows.Add(dr);

dr = dt.NewRow();

dr["field1"] = "test";

dr["field2"] = 460.02;

dt.Rows.Add(dr);

dr = dt.NewRow();

dr["field1"] = "test";

dr["field2"] = 460.02;

dt.Rows.Add(dr);

dr = dt.NewRow();

dr["field1"] = "test1";

dr["field2"] = 4600.05;

dt.Rows.Add(dr);

dr = dt.NewRow();

dr["field1"] = "test1";

dr["field2"] = 474.58;

dt.Rows.Add(dr);

WorkbookDesigner designer = new WorkbookDesigner();

//Non merged - OK

designer.Workbook.Open(@"..\..\NonMerge.xls");

designer.SetDataSource(dt);

designer.Process(true);

designer.Save(@"..\..\NonMergeOut.xls", FileFormatType.Default);

//Merged - ERROR !!!

//Content of Cell (B7=”field2”) is disappeared

designer.Workbook.Open(@"..\..\MergeFormat.xls");

designer.SetDataSource(dt);

designer.Process(true);

designer.Save(@"..\..\MergeFormatOut.xls", FileFormatType.Default);



Templates in attachment


<!–[if gte mso 10]>

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Обычная таблица"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0cm 5.4pt 0cm 5.4pt; mso-para-margin:0cm; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:Calibri; mso-fareast-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi; mso-fareast-language:EN-US;}

<![endif]–>

Thanks, Evgeny

Hi,

Thank you for considering Aspose.

We have found your mentioned issue after an initial test. We will look into it and get back to you soon. Your issue has been registered in our issue tracking system with issue id CELLSNET-11778.

Thank You & Best Regards,

Hi,

Thank you for considering Aspose.

Please try the attached latest version of Aspose.Cells. We have fixed your mentioned issue.

Thank You & Best Regards,

Hi!

I tried the new version and it now works. Thank you.

Regards, Evgeny

The issues you have found earlier (filed as 11778) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.