We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Cell.HtmlString- doesn't highlight the color properly on "Code Commented" part

Hi,


We have tried to add nested font color on ‘Code - Commented’ part. But it doesn’t work.
Herewith we have attached our issue as image as well as the sample code.

Please clarify our questions,

Thanks,
Renga.

Hi,


Thanks for the sample code, screenshot and details.

Please change the following lines of code (part of HTML string):
i.e.,

cell.HtmlString ="
<font color=‘Green’>/---------------------------------------------------------------------------------------
" +

“Auther :” +
"Author :---------------------------------------------------------------------------------------/

";

to:

cell.HtmlString = "
<font color=‘Green’>/---------------------------------------------------------------------------------------
" +

“Auther :” +
"Author :---------------------------------------------------------------------------------------/

";


it should work fine for your needs.

Thank you.

Hi Amjad Sahi,


Thank you for your response.
Since the HTML is coming from other resource (nested structure), we cant change or alter the HTML string.
Could you suggest any other solution?

Thanks in advance.

Regards,
Renga.

Hi,


We are sorry that the workaround does not fit your needs. I am afraid, there may not be any other way around to cope with it. I have to log your issue with an id “CELLSNET-45326” into our database:
CELLSNET-45326 - Cell.HtmlString does not highlight the nested font color properly.

Our concerned developer from product team will investigate and look into your issue soon.

Once we have an update on it, we will let you know here.

Thank you.

Hi,


This is to inform you that we have fixed your issue (logged earlier as “CELLSNET-45326”) now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.

Once the fix is available for public use, we will share the Download link here.

Keep in touch.

Thank you.
Hi,

Thanks for using Aspose.Cells.

Please download and try the following latest fix

Aspose.Cells for .NET v17.4.5 (.NET 2.0) compiled in .NET Framework 2.0.
Aspose.Cells for .NET v17.4.5 (.NET 4.0) compiled in .NET Framework 4.0.

and let us know your feedback.
Hi Shakeel Faiz,

Thank You for information.

We have tested new version and the problem has been solved.

Many Thanks and Kind Regards,
Renga
Hi,

Thanks for sharing good news with us and using Aspose.Cells.

We are pleased to know that your issue is resolved with the latest fix. Let us know if you encounter any other issue, we will be glad to look into it and help you further.

The issues you have found earlier (filed as CELLSNET-45326) have been fixed in Aspose.Cells for .NET 17.5.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

The issues you have found earlier (filed as CELLSNET-45326) have been fixed in Aspose.Cells for .NET 17.5.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.
(2)

The issues you have found earlier (filed as ) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by MuzammilKhan