We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Cell.HtmlString not processing simple html properly

I'm using Aspose.Cells version 5.3.3.0 for .Net in an .Net 4.0 application.

I am trying to insert multiple blocks of data into a cell. Each block of data can contain multiple lines and each block is preceded by a bold title, for example:

Genre: Genre type
Title: Title text
Details: Description text, which of course could be quite long and should then be wrapped as one would expect.
Packaging: packaging details
Weight: package weight

I figured that the easiest way to accomplish this was to write this text in html and to render it in Aspose.Cells with Cell.HtmlString.

I wrote the following html for the above example (brief):
Genre: Genre type
Title: Title text
...

Pretty basic stuff, not much room for error. But Aspose Cells rendered the html as follows:

Genre: Genre type
Title: Title text

It seems that only the last closing "" is recognized (In my first attempt I used the strong tag with the same result). I didn't even get to indenting text because I can't find any documentation on what the HtmlString member supports. Using rich text formatting would be difficult because all data in the cell is composed dynamically.

Is this a bug? Is there any documentation on exactly what kind of HtmlString member supports? Has anyone had any luck with using HtmlString for formatting issues? If so, could you maybe post some clear examples?

Thanks for any help.


Hi,

Thanks for your question and using the Aspose.Cells for .NET.

Please download and try the latest version:
Aspose.Cells for .NET (Latest Version)
we have fixed many html related bugs in it, so it should work fine.

Please let us know your feedback.

I have solved the ‘bold’ problem with a work around. If I write the html as follows the begin and end b tags are recognized successfully:


Genre: Genre type
Title: Title text

apparently they need to be included in another container to be recognized.

Hi,

It’s good to know, your problem is resolved now.

If you get any other question, please feel free to post. We will help you asap.