We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Change table position in PowerPoint 2003 doesn't work

Hi!

I am trying to set ‘Y’ property for table, like so:

table.setY(100);

and I have exception:

Exception in thread "main" com.aspose.slides.PptEditException: Can't modify property Y of the Rectangle object because it is a subshape of the Table object.
	at com.aspose.slides.Rectangle.do(Unknown Source)
	at com.aspose.slides.Rectangle.if(Unknown Source)
	at com.aspose.slides.Table.if(Unknown Source)
	at com.aspose.slides.Shape.setY(Unknown Source)
	at net.defgo.aspose.NewTableCheckPP2003.main(NewTableCheckPP2003.java:66)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:601)
	at com.intellij.rt.execution.application.AppMain.main(AppMain.java:120)

You can find full code in attachment.



Question is: how can I change position of table?

I am using Aspose.Slides 7.5.0

Hi Nikolay,

I have observed the stack trace shared. I suggest you to please try using Aspose.Slides for Java 7.6.0 on your end. If there is still an issue then please share the sample presentation with us that I can work over to help you further.

Many Thanks,

Hi Mudassir!

I have tried my code with Aspose.Slides 7.6.0, and bug is still here. And I can’t share sample presentation with you, because I can’t create it (because of this bug). I have attached sample code to my first message, you can reproduce this bug with it.

Hi Nikolay,

I have worked with the sample code and have been able to reproduce the issue specified. An issue with ID SLIDESJAVA-34056 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

We are sorry for your inconvenience,

Ok, thank you for help!

Same issue exists with .NET dll. Is there a solution available?

Hi Shishir,

Thanks for inquiring Aspose.Slides.

I agree with you point of view that the same issue exist in Aspose.Slides for .NET as well. An issue with ID SLIDESNET-35172 has already been created in our issue tracking system to investigate and resolve the issue for .NET API as well. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

PS: Once the issue will be resolved for .NET, it will then be ported for Aspose.Slides for Java in next subsequent release.

Many Thanks,

The issues you have found earlier (filed as SLIDESJAVA-34056) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.