Free Support Forum - aspose.com

Chart disappearing in ODS format

c# :
static void Main(string[] args)
{
Console.WriteLine(CellsHelper.GetVersion());
Workbook wb = new Workbook(@“allDiagrams_before.ods”);
wb.Settings.Region = CountryCode.USA;
wb.Save(@“allDiagrams_after.ods”);
}

it’s the exact same result as if i haven’t added wb.Settings.Region = CountryCode.USA;
allDiagrams_before.PNG (119.9 KB)

allDiagrams_after.PNG (116.7 KB)

Location : France
Format : French (France)

@vviroleau,

Thanks for the screenshots and further details.

Please try the updated code segment, it should work fine now:
e.g
Sample code:

c# :
static void Main(string[] args)
{
Console.WriteLine(CellsHelper.GetVersion());
Workbook wb = new Workbook(@“allDiagrams_before.ods”);
wb.Settings.Region = CountryCode.UnitedKingdom;
wb.Save(@“allDiagrams_after.ods”);
}

Let us know your feedback.

I have tried :
wb.Settings.Region = CountryCode.UnitedKingdom;
or
wb.Settings.Region = CountryCode.USA;
or
wb.Settings.Region = CountryCode.France;
or
wb.Settings.Region = CountryCode.Default;

None of these worked. The output is exactly the same as the screenshot i sent you yesterday.

@vviroleau,

Although I have reproduced the issues partially (Not all the issues are reproduced) but I have logged the following tickets for your mentioned issues into our database for evaluation:

  1. CELLSNET-47038 - Line charts in ODS file are not rendered fine when open/save via Aspose.Cells
    This ticket is covering the issues:
  • 1- Diagram point only is transformed in line only (Sheet2, line 1 diagram 1)
  • 2- Lines and point is transformed in line only (Sheet2, line 1 diagram 2)
  • 3- Line 3D is wrong, the line is not displayed (Sheet2, line 1 diagram 4)
  1. CELLSNET-47039 - XY scatter charts in ODS file are not rendered fine when open/save via Aspose.Cells
    This ticket is covering the issues:
  • 4- XY scatter points only, the points have disappeared (Sheet2, line 2 diagram 1)
  • 5- XY scatter points and line is transform in XY scatter line only (Sheet2, line 2 diagram 2)
  • 6- XY scatter 3D lines is wrong, the line is not showing (Sheet2, line 2 diagram 4)
  • 10- All Line, XY scatter and net diagram have a different font after the save.The line is thicker and the color has changed. (Sheet2, line 1, 2 and 4)
  1. CELLSNET-47040 - Line charts in ODS file are not rendered fine when open/save via Aspose.Cells
    This ticket is covering the issues:
  • 7- Net points only is wrong, the points are not showing (Sheet2, line 4 diagram 1)
  • 8- Net points and line is transformed in line only (Sheet2, line 4 diagram 2)
  • 9- Net filled is completely different, it’s like it has been transformed in bar ? (Sheet2, line 4 diagram 4)
  • 10- All Line, XY scatter and net diagram have a different font after the save.The line is thicker and the color has changed. (Sheet2, line 1, 2 and 4)

We need to investigate your mentioned issues thoroughly since your regional settings is France. We will look into these issues and try to figure these issues out soon.

Once we have an update on any of the issues, we will let you know.

@vviroleau,
For your issue CELLSNET-47023, please try our latest version/fix: Aspose.Cells for .NET v19.11.7:
Aspose.Cells19.11.7 For .Net2_AuthenticodeSigned.Zip (5.0 MB)
Aspose.Cells19.11.7 For .Net4.0.Zip (5.0 MB)
Aspose.Cells19.11.7 For .NetStandard20.Zip (4.1 MB)

Your issue should be fixed in it.

Let us know your feedback.

I made a test using the 19.11.7 and forcing the currentculture to us :

CultureInfo.CurrentCulture = CultureInfo.GetCultureInfo(“en-US”);
Workbook wb = new Workbook(@“allDiagrams_before.ods”);
wb.Save(@“allDiagrams_after_usa.ods”);

And now the points are showing !!

So for me there are 4 bugs :
BUG1 : Points are not rendering and fonts is changed in ODS file when open/save via Aspose.Cells if currentculture is not en-US

  • 2- Lines and point is transformed in line only (Sheet2, line 1 diagram 2)
  • 4- XY scatter points only, the points have disappeared (Sheet2, line 2 diagram 1)
  • 5- XY scatter points and line is transform in XY scatter line only (Sheet2, line 2 diagram 2)
  • 7- Net points only is wrong, the points are not showing (Sheet2, line 4 diagram 1)
  • 8- Net points and line is transformed in line only (Sheet2, line 4 diagram 2)
  • 10- All Line, XY scatter and net diagram have a different font after the save.The line is thicker and the color has changed. (Sheet2, line 1, 2 and 4)

BUG2 : Points only is transformed in line and point in ODS file when open/save via Aspose.Cells

  • 1- Diagram point only is transformed in line only (Sheet2, line 1 diagram 1)

BUG3 : 3D lines and 3D wy scatter 3D lines are wrong in ODS file when open/save via Aspose.Cells

  • 3- Line 3D is wrong, the line is not displayed (Sheet2, line 1 diagram 4)
  • 6- XY scatter 3D lines is wrong, the line is not showing (Sheet2, line 2 diagram 4)

BUG4 : Net filled diagram is wrong in ODS file when open/save via Aspose.Cells
9- Net filled is completely different, it’s like it has been transformed in bar ? (Sheet2, line 4 diagram 4)

remaining_bugs_19_11_7.png (226.8 KB)

@vviroleau,

We fixed 1) but we could not find 2), so we cannot fix it, i.e.,:

2- Lines and point is transformed in line only (Sheet2, line 1 diagram 2)

For

3- Line 3D is wrong, the line is not displayed (Sheet2, line 1 diagram 4)

I am afraid, 3D charts are not supported for .ods file now. This issue cannot be fixed in short time.

We will continue to evaluate other issues and will update you once any new information is available.

Hello,

Did you have a look at my printscreen : remaining_bugs_19_11_7.png ?

The bug4 and bug2 are still open i think

@vviroleau,

I did not tell you that 1 (“BUG2”) is fixed in Aspose.Cells for .NET v19.11.7, we will provide the fix in coming days. Please spare us time and once we have any new information on any issue, we will update you.

@vviroleau,

Could you explain more about “different font” issue?

It’s the thickness and the color of the line that changes when the currentculture is FR.

@vviroleau,

Thanks for the details.

We understand it now. We will try to consider this when resolving the issue(s).

Once we have an update on any of the logged issues, we will let you know.

@vviroleau,

Please try our latest version/fix: Aspose.Cells for .NET v19.11.8 (attached).

Your issue (logged as “CELLSNET-47040”) should be fixed in it.

Let us know your feedback.
Aspose.Cells19.11.8 For .Net2_AuthenticodeSigned.Zip (5.0 MB)
Aspose.Cells19.11.8 For .Net4.0.Zip (5.0 MB)

A post was split to a new topic: Charts not rendered properly while loading and saving ODS

@vviroleau,

This is to inform you that we have fixed your issues (“CELLSNET-47023” and “CELLSNET-47038”) now. We will soon provide you the fixed version (we will share the Download link to the fixed version) after performing QA and incorporating other enhancements and fixes.

Thank you.

Do you know when it will be available as a Nugget package ?

@vviroleau,

Hopefully we will publish our next official release (e.g Aspose.Cells for .NET v19.12) on Downloads/Nuget repos. before the end of this week or so.

Keep in touch.

The issues you have found earlier (filed as CELLSNET-47023,CELLSNET-47038) have been fixed in Aspose.Cells for .NET v19.12. This message was posted using Bugs notification tool by Amjad_Sahi

@vviroleau,

This is to inform you that we have fixed your issues (“CELLSNET-47039” and “CELLSNET-47040”) now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.