Free Support Forum - aspose.com

Chart Title color off when exporting to PDF


#1

Hi

we’re using Aspose Slides .NET 18.12.0 to convert a PPTX file to a PDF. Most of it seems to work ok, but we’re having a few issues with charts and colors:

Rendered by Powerpoint PDF export (307.8 KB)
Rendered by Aspose PDF export (272.4 KB)

You can see that the colors rendered by Aspose are off. The title is black instead of white, the colors in the chart are switched as well. Also font size seems to be a bit off.

This seems to be a general issue with charts in the whole document. Also the waterfall chart on slide 6 is not rendered at all.

The presentation is attached in the following zip file:
2016Test.zip (2.3 MB)

Here’s the PDF rendered when exporting using Powerpoint Save as PDF:
2016Test_exported_using_powerpoint.pdf (1.3 MB)

And here’s the PDF rendered by Aspose:
tmpFA17.tmp.pdf (1.0 MB)

using the following C# code:

using System;
using System.Collections.Generic;
using System.Diagnostics;
using System.IO;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using Aspose.Slides.Warnings;

namespace AsposePowerpointExportSample
{
    class Program
    {
        static void Main(string[] args)
        {
            Aspose.Slides.License slides = new Aspose.Slides.License();
            slides.SetLicense("Aspose.Slides.lic");

            var inputFilePath = "2016Test.pptx";

            var presentation = new Aspose.Slides.Presentation(inputFilePath);
            var saveOptions = new Aspose.Slides.Export.PdfOptions
            {
                JpegQuality = (byte)80,
                BestImagesCompressionRatio = true
            };

            var tempFilePath = Path.GetTempFileName() + ".pdf";
            using (var fs = new FileStream(tempFilePath, FileMode.Create))
            {
                presentation.Save(fs, Aspose.Slides.Export.SaveFormat.Pdf, saveOptions);
                fs.Flush();
            }

            presentation.Dispose();

            Process.Start(tempFilePath);
        }
    }
}

Is this a bug in Aspose or are there any options that can be tuned to fully support this file?


#2

@ppcg,

I have worked with the presentation shared by you using Aspose.Slides for Java 18.12.0 and have been able to observe the issue. A ticket with ID SLIDESNET-40887 has been added in our issue tracking system to resolve the issue. This thread has been associated with the ticket so that we share notification with you once issue will be fixed.