We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Charts not recalculating properly - remnants of previous data remaining

Hi,

I have a workbook with some raw data in one sheet. A Pivot Table on another sheet and a Chart on its own sheet have been built upon this data using a Range Name for the data source.

My goal is to replace the raw data sheet, recreate the range name, recalc everything and have the Pivot Table/Chart reflect the new data.

My problem is that when I add small amounts of data, the chart displays “phantom” bars that were from the previous data set. This behavior is always reproducible when saving as PDF. I have seen it happen with saving to XLSX too, but this strange behavior is less common with Excel native formats.

I have attached sample outputs of the same workbook. In this case, the PDF version has the phantom bars and the Excel file does not.

I can’t tell my customers, “Don’t run small reports” Can you help me?

Thank you,
Rick

Hi,


Thanks for your posting and using Aspose.Cells.

We were able to observe this issue and logged it in our database for investigation and for a fix. Once, the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as

  • CELLSNET-45426 - Chart data is unable to refresh data from Pivot Table

Hello Shakeel,
Is there any progress on this issue?
Thank you,
Rick

@rick855d4

Thanks for using Aspose APIs.

We are afraid there is no update for you at this moment regarding this issue. However, we have logged your comment in our database against this issue and requested the product team to provide some fix or ETA for this issue. Once there is some news for you, we will update you asap by posting in this thread.

@rick855d4,

Thanks for using Aspose APIs.

We are working over this issue and we are hopeful, we will be able to provide you a fix for this issue (i.e. CELLSNET-45426) before 26 July, 2017. Once, the fix is available for you, we will let you know asap.

@rick855d4,

This is to inform you that we have fixed your issue (logged earlier as “CELLSNET-45426”) now. Hopefully we can provide you the fix in the next few days after performing QA and incorporating other enhancements and fixes.

Thank you.

The issues you have found earlier (filed as CELLSNET-45426) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.