Free Support Forum - aspose.com

Check Mark is not displayed in PDF

Dear Team,


I am using the “Aspose Words for JAVA” product to generate Word and PDF Documents.

We have a requirement to display Check Marks in Final rendered Output Word and PDF Document. I used MailMerge functionality to generate the documents. When we see the output Word Document is displaying the check marks correctly, but whereas in PDF the check mark is displayed as a box instead of check mark.

And here i used toggle fields to display the check marks so when a value is there it will be displayed otherwise no.

For reference I am attaching the input and output documents.

Kindly help in resolving the issue.

Thanks and Regards
Pradeep

Hi Pradeep,


Thanks for your inquiry. Do you see the same problem when converting “Word Output.doc” to PDF using the code mentioned in this article:
http://www.aspose.com/docs/display/wordsjava/How+to++Convert+a+Document+to+PDF

After an initial test with Aspose.Words for Java 15.7.0, I was unable to reproduce this issue on my side (please see attached 15.7.0.pdf). I would suggest you please upgrade to the latest version of Aspose.Words. You can download it from the following link. I hope, this helps.
http://www.aspose.com/community/files/72/java-components/aspose.words-for-java/default.aspx

Best regards,

Dear Team,



Sorry for delayed response.



I tried with the resolution steps provided

1. We are using the code to get PDF document

“doc.save(outStream, FormNameSave.PDF);”



Even we tried to load and set the fonts to take it manually from repository, but we are facing the same problem.



tried with the code:

FontSettings.setFontsFolder("/Data/fontslocation/fonts", false);



also tried with the below code:

FontSettings.setFontsFolder("/Data/fontslocation/fonts", true);



[Setting of Fonts code is written before “doc.save”]



2. Tried to deploy the latest JAR as mentioned. We are facing the same issue.



Kindly let us know if we are missing out any other process or code to get the output. Please help us in resolving the issue.



Thanks and Regards

Pradeep

Dear Team,



To give even more details about the system properties, the application is deployed in the server which has

1. UNIX O/S

2. Java Application is running on JBOSS WebServer installed on UNIX.



And

When I am running it as localhost application it is working fine. Here my desktop level properties are

1. Windows 7 O/S

2. Java Application running in Apache Tomcat 7



Whether there will be any setting I need to do at WebServer level or at O/S level.



Please help us in this regard for resolving the issue.



Thanks and Regards

Pradeep

Hi Pradeep,


Thanks for your inquiry. Please try the last example from following article:
http://www.aspose.com/docs/display/wordsjava/How+to++Specify+True+Type+Fonts+Location

Also, do you see any warnings generated by Aspose.Words. Aspose.Words provides the IWarningCallback interface which can be implemented to receive warnings of potential fidelity loss when loading or saving a document. There are several types of notifications that Aspose.Words will alert the user to using IWarningCallback. For example, please see the following article:
http://www.aspose.com/docs/display/wordsjava/How+to+Receive+Notification+of+Missing+Fonts+and+Font+Substitution+during+Rendering

Best regards,