Free Support Forum - aspose.com

CloneSlide does not complete for certain PPTs

Hi there, Quick support will be appreciated.
--------------------------
ASP.NET 2.0, C#, MS VS 2003,
Can not attach the PPT as it is confidential
---------------------------
The CloneSlide method: never completes for certain PPT files, (Though most PPTs are fine).
Main code is as follows:
The arguments to CloneSlide method are all FINE.
------------------------------
// Required by CloneSlide functionality
SortedList temp = new SortedList();

// Copy one slide only
Slide sourceSlide=sourcePresentation.GetSlideById( slideIdToCopy );

int newSlidePosition=targetPresentation.Slides.LastSlidePosition + 1;

Slide SlideTemp = sourcePresentation.GetSlideById( slideIdToCopy );
int nTemp = targetPresentation.Slides.LastSlidePosition + 1;

Slide s = sourcePresentation.CloneSlide
(
SlideTemp,
nTemp ,
targetPresentation,
temp
);
--------------------------

Thanks.

Manu Agrawal

Dear Manu,

Regarding CloneSlide, one problem has been recently identified and fix will be available by tomorrow. Please check this thread.

Also, does any exception occurs, or it just simply times out without any exception.

Are you using Aspose.Slides for .NET 2.7.0.0 or some other version? Please mention.

Also, you can keep your post private, there is a check box to keep the post private on new post UI. Keeping post private you can safely send your confidential data to aspose staff.

You can also send me ppt file using www.yousendit.com , upload there and send me its link.

Dear Shakeel,
We do not get any exception,
The request never completes.
The assembly version is 2.4.5.0

I am really sorry but the PPT can not be given to anybody outside our organization.

Your quick response is appreciated. I am waiting for the bug fix.


Please update to the latest versions 2.6.26 or 2.7.0.
Old versions can’t work with presentations created in PP2007.