CloneSlide example doesn't make perfect copies?


#1

Hi,

I’m having some issues cloning slides with Aspose.Slides 1.6.12.0. I run the following:

java -cp .;aspose.slides.jar CloneSlide empty1.ppt test1.ppt out1.ppt

where “empty1.ppt” just has a title slide and “test1.ppt” uses the Wartermark.pot slide design and has a couple slides. (Attached are the source and test files.) It almost works, except that in “out1.ppt”, all bullets have the number 10 inside them (which is different from the original slide design).

I tried allowing each slide to have its own master (and also not allowing that) by not clearing the map of IDs between cloning operations, but both cases resulted in the same strange bullets.

Ultimately, I was trying to split a presentation into multiple presentations, with one new presentation per original slide. But this issue shows up there, too.

By the way, the version of PowerPoint used is 2003 SP2.

Thanks,
Michael


#2

Hello Michael,

This problem has been fixed.
New hot fix will be available today or tomorrow.


#3

Thanks for looking into this! I look forward to testing the fix.

Michael


#4

Sorry for delay, we found one more problem and working with it yet.
Hot fix will be available on this week. Probably on weekends.


#5

Thanks for working on the problem. The lastest hotfix now works on the test example.

Michael