We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Com.aspose.slides.c.a.ah: Input string was not in the correct format

Hello,

i am using Aspose Slides for Java 6.9.1

i am trying to read the attached .pptx file.

When the following line executes:

PresentationEx pres = new PresentationEx(“TestTemplate.pptx”); (see attachement)

i get the above exception.
The file im trying to read was created by jasper reports 3.7.6. The file opens fine in MS-Powerpoint 2010 and when opened it looks exactly like i expected from Jasper generation. When the file is created by jasper reports the size is about 9kb. When i open this File inside Powerpoint 2010 and resave it the size grows to 16k. After that Aspose Slides for Java is able to read the resaved Powerpoint without any Problems.

I also tried to read the pptx-file with version 2.9.1 of Aspose Slides for Java but no success. There it dont even tells the above Exception but simply throws a NullPointer Exception deep inside obfuscated Aspose Slides Classes.

I also tried using LoadOptions while loading the Powerpoint but had noc look.

I even tried to Load the file with POI as XslfSlideShow and resaved it with that, but had no Luck ether.

Like always because of the obfuscated code from Aspose, not decompileable classes and non existing sources i am not able to debug anything. Is there a way for customers to get hands on sources. If i had the sources i would have been able to track down the Problem in Minutes but now i am wasting hours again.

Thanks in advance for any help

Hi Chris,


Thanks for inquiring Aspose.Slides.

I have observed the presentation file shared and have been able to observe the issue specified. An issue with ID SLIDESJAVA-33730 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

We are sorry for your inconvenience,

The issues you have found earlier (filed as SLIDESJAVA-33730) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.