Free Support Forum - aspose.com

Components

We acquired a license component "Aspose.Words for SharePoint" and installed in our server. It worked perfectly.

After this, we acquired a license component "Aspose.Cells for SharePoint" and tried to install in the same server, however, is was not possible because the ID Solution is the same of the component "Aspose.Words for SharePoint. " See picture attached.

SolutionID = "f4fdd866-0903-4174-991b-71e15aeb81c0

We need a new file "Aspose.Cells for SharePoint" to be sent with a different ID Solution so we can use the two components on our server. <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Can you help us ?

Thank you.

Hi ,

We had check your issues and tested it.

But we do not find your issues .

Our test environment : windows server 2003 x86 , Share Point 2007, Aspose.Cells for Share Point 2.0.1 and Aspose.Words for Share Point 2.2.0.

Our steps:

1. Download Aspose. Words for Share Point 2.2.0 and install Aspose.Cells for Share Point 2.0.1.

2. Export different folders.

3. Install Aspose. Words for Share Point 2.2.0 .

4. Install Aspose.Cells for Share Point 2.0.1.


Please tell us your running environment and steps.

We will go on check.

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /> Hi, thanks for your reply. Below are some more information, as you asked.

OUR CURRENT STATUS:

1. Aspose. Words for Share Point LICENCE 2.2 - installed and working

2. Aspose. Cells for Share Point - installed and working

OUR NEXT STEPS:

3. Download Aspose.Cells for Share Point LICENCE 2.2

4. Trying to install Aspose.Cells for Share Point LICENCE 2.2

5. ERRO “A solution with the same name ‘aspose.words.sharepoint.license.wsp’ or id ‘f4fdd866-0903-4174-991b-71e15aeb81c0’ already exists in the solution store. Aspose.Cells.SharePoint.License.wsp: The Solution installation failed.”

6. Then we opened the mainfast.xml from each .wsp (‘aspose.words.sharepoint.license.wsp’ and Aspose.Cells.SharePoint.License.wsp), renaming the .wsp to .cab, and we found the SAME solution ID in both the mainfast.xml.v

You have been informed that the file 'Aspose.Cells.SharePoint.License.wsp' was not provided by you, however, the instructions for installing the license, this file is listed in step 1 as the line below:

1. Run stsadm to add the solution to the SharePoint solution store: stsadm.exe-o-filename addsolution Aspose.Cells.SharePoint.License.wsp

In implementing the above procedure, the error occurs, as shown in the attachments.

We urgently need a more elaborate, a step-by-step instructions on how to install this license without conflict with the license Aspose.Words.SharePoint.

Can you help us please ?

Hi,

We have logged your issue as CELLSSP-27174. We will update you asap.

Hi,

We are solving this issues.

Please try following way.

Copy Aspose.Cells.SharePoint.lic file into following folder: C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\Aspose.Cells.SharePoint.

Solved !!

Thank you for your support.