We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

CompressImages renders PDF with artifact image

The following code:

 > Document doc = new Document(fileName);
                        doc.OptimizeResources(new Document.OptimizationOptions()
                        {
                            LinkDuplcateStreams = true,
                            RemoveUnusedObjects = true,
                            RemoveUnusedStreams = true,
                            CompressImages = true,
                            ImageQuality = 90,
                            UnembedFonts = false
                        });
                        doc.Save(tempOptimizedPdf);

Converts the following PDF Resulterende pdf.pdf (79.1 KB)

They are scanned with new Rico scanners.

When setting CompressImages = false in the above code, the resulted pdf is a good one.

Could you advice how to proceed with this?

We are using: Aspose.PDF 18.6.1 . We tried Aspose.PDF 18.10.0 , but we got the same result.

Yours sincerely,

Kristof

@Luk_De_Reu

Thanks for contacting support.

We have tested the scenario in our environment and managed to observe that images got turned black after setting CompressImages option as true. For the sake of correction, we have logged this issue as PDFNET-45621 in our issue tracking system. We will further investigate it in details and keep you posted with the status of its correction. Please be patient and spare us little time.

We are sorry for the inconvenience.

Is there a way, to see this issue on your backend log, so we can supervise, without polling ‘what is the status’. That’s for you guys no fun, and for us also no fun…

And off course, is there any news?

Thanks!

Kristof

@Luk_De_Reu

Thanks for your inquiry.

As issue has been logged in our internal issue management system, I am afraid that you may not be able to access it. However, we will definitely let you know in case of further updates regarding resolution progress. Furthermore, please note that the issue has been logged under free support model where issues are resolved on first come first serve basis and have low priority unlike paid support model where issues are dealt with high precedence.

In case your issue is a show stopper or blocker and needs to be resolved on urgent basis, you may please check our priority support option. As soon as we have some definite updates regarding resolution of the issue, we will surely inform you. Please spare us little time.

We are sorry for the inconvenience.

In understand the freemodel. Could you check if the issue has been fixed and from what version?

@Luk_De_Reu

Thanks for sharing your concerns.

We regret that issue is not yet fixed due to other high priority issues. However, we have recorded your concerns and will definitely consider them during issue investigation. We will try to share possible ETA as soon as investigation of the issue is complete. Please spare us little time.

We are sorry for the inconvenience.