We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Conditional formatting in Pivot table doesn't work in a copied sheet (OP-7317)

Hi Support,
I have a sheet with a conditional formatting set to a pivot table, after the copy of the sheet, in the new sheet the conditional formatting are wrong, see the attached pdf.
I attach a simple program to replicate the issue.

OP-7317-2.zip (49.1 KB)
ConditionalFormatting.pdf (438.9 KB)

@andreagasparin,

Thanks for the sample project with template file and screenshots.

After an initial test, I am able to observe the issue as you mentioned (via screenshots pasted in the PDF file) by using your sample project with your template file. I found that conditional formatting in pivot table does not copied properly in the copied sheet.

I have logged a ticket with an id “CELLSNET-46477” for your issue. We will look into it soon.

Once we have an update on it, we will let you know.

@andreagasparin,

This is to inform you that we have fixed your issue (logged earlier as “CELLSNET-46477”) now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.

@andreagasparin,

Please try our latest version/fix: Aspose.Cells for .NET v19.1.3 (attached)

Your issue should be fixed in it.

Let us know your feedback.
Aspose.Cells19.1.3 For .Net2_AuthenticodeSigned.Zip (4.7 MB)
Aspose.Cells19.1.3 For .Net4.0.Zip (4.8 MB)

The issues you have found earlier (filed as CELLSNET-46477) have been fixed in Aspose.Cells for .NET v19.2. This message was posted using BugNotificationTool from Downloads module by Amjad_Sahi