Content Missing from Html to Excel Conversion

Hi Team,

I am using Aspose.Cells latest version in dot net 4.5

I am converting Excel into Html and conversion is perfectly okay.
Now when I am regenerating back to xlsx from html, I am getting perfect format but content is missing in regenerated file…which is present in html file

please find attached folder which contains screenshot of content missing, html file and regenerated file. (345.4 KB)


Thanks for your query.

I have tried the scenario using latest version Aspose.Cells for .NET 18.12.9 with the following sample code but could not observe issue. Please give it a try and share the feedback.

HtmlSaveOptions htmlSaveOptions = new HtmlSaveOptions(SaveFormat.Html);
Workbook wb = new Workbook(path + "sample.xlsx");
wb.Save(path + "output.html",htmlSaveOptions);

HTMLLoadOptions options = new HTMLLoadOptions(LoadFormat.Html);
Workbook wb2 = new Workbook(path + "output.html", options);
wb2.Save(path + "output2.xlsx", SaveFormat.Xlsx);

Aspose.Cells18.12.9 For .Net4.0.Zip (4.7 MB)
Aspose.Cells18.12.9 For .Net2_AuthenticodeSigned.Zip (4.7 MB) (362.0 KB) (157.5 KB) (362.8 KB)

Hi @ahsaniqbalsidiqui

With Aspose.Cells 18.12.9 version Issue is solved in HTML but for regeneraeted File still content is missing.
I checked your zip file( even there I am still seeing same Issue.

Please check sheet name (2)process 14th row C, D,E columns Data is missing.


Can you please copy the text or upload a screenshot as I can not find issue in file.
CompareHTML.JPG (39.8 KB)

please find attached screenshot which contains difference of html file and
Excel_Error.JPG (173.7 KB)


There seems to be some confusion as the source file “Customer Management Maturity Model v5 03232014 FINAL2.xlsx” shared here also does not contain mentioned text in row 14 column C,D and E. Please verify that correct file is shared with us.

Please find attached files again.

this contain source file, Html file converted from source file and Regenerated file created from excel file.
crerated from the aspose.cells 18.12.9
Screenshots provided as well

please go to sheet name (2)process row 13th.
In html I am getting all data but when I am regenerating excel back from html 13th row data is missing(there are many boolean points but able to see only one boolan point data). (491.4 KB)


We were able to observe the issue but we need to look into it more. We have logged the issue in our database for investigation and for a fix. Once, we will have some news for you, we will update you in this topic.

This issue has been logged as

CELLSNET-46547 - Content Missing from HTML to Excel Conversion

Can you inform in which type of Html we may face this issue for future documents.


As we just logged the ticket, so could you spare us a little time (3-5 days or so) for complete evaluation and investigation for your issue.

Once we have an update on it, we will let you know here.

Hi team,

can this issue be excepted to be solved in further releases?


This issue is in progress and we will let you know once there are some updates.


Please try our latest version/fix: Aspose.Cells for .NET v19.1.3 (attached)

Your issue should be fixed in it.

Let us know your feedback.
Aspose.Cells19.1.3 For .Net2_AuthenticodeSigned.Zip (4.7 MB)
Aspose.Cells19.1.3 For .Net4.0.Zip (4.8 MB)

The issues you have found earlier (filed as CELLSNET-46547) have been fixed in Aspose.Cells for .NET v19.2. This message was posted using BugNotificationTool from Downloads module by Amjad_Sahi