We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Conversion of PDF to Postscript takes long and produces a big file

Hello all, we are using in our product Aspose.pdf to convert PDF to Postscript via viewer.printLargePdf.
Our customer has a big original PDF file (e.g. 3MB). We found out that with using the methods above it takes almost 6-9 Minutes to convert it and the resulting file size is ca. 140-200MB.
Even a 1MB File will be converted to 48MB.

Which is, from our point of view, too long and too big to handle in our application.

PDF_TO_PS_conversion2.jpg (137.7 KB)

I have prepared a unit test class and have added as well some example files which should be converted.

docconverter.zip (3.7 MB)

For running the unit test:

  1. You need to set up a printer on your laptop/PC with name ‘PS_Printer’ (or similar) which uses a Postscript driver, e.g. HP Universal PS Printing or similar. It doesn’t matter what driver I use, the size is almost the same.
  2. Please setup in the init() method the license information for Aspose.PDF, as if no license used, the converted document contains only 4 pages ;-), which is not correct.
  3. Put the attached PDF file into a folder C:\temp\xxxxx.pdf - adjust the folder name, if necessary, to your environment.
    We have used Aspose.pdf version 20.2 and 20.3, but with the same bad results.
    Are you aware of these problems and do you have a solution for this?

Thanks a lot for your support
Anne

@wroet001,

Can you please try to use Aspose.PDF latest version 20.4 and if there is still an issue than please share complete environment details along with JDK version details so that we may further investigate this issue on our end.

Hello Adnan, I’m using the following JDK version.

JAVA_VERSION=“1.8.0_212”
OS_NAME=“Windows”
OS_VERSION=“5.2”
OS_ARCH=“amd64”
SOURCE=""

I’m running the unit test on Eclipse and a Windows 10 PC with preparing a printer PS_Printer and using driver HP Universal PS Printing. it can be downloaded here.
https://ftp.hp.com/pub/softlib/software13/COL40842/ds-99376-23/upd-ps-x64-6.9.0.24630.exe

Windows:
2. Open the CONTROL PANEL on the server and select ADMINISTRATIVE TOOLS.
3. Open the PRINT MANAGEMENT.
4. Select PRINT SERVERS -> PRINTERS.
5. Select your printer and open the printer properties.
6. Select port FILE.
Printer port

image.png (57.7 KB)

  1. In tab GENERAL, enter the name PS_Printer for the printer.

What else environment information do you need?

Regarding 20.4, I’m currently not able to test with 20.4, as this month our license was expired. :-\
We are currently renewing it.
But, I had a look into the release notes for 20.4, there are only a few tickets solved, I don’t expect any changes on this, means it would be the same bad performance and big size. I will share later the results with 20.4.
Would you please nevertheless have a look on this problem. :slight_smile:
Thanks a lot
Anne

@wroet001,

I like to inform I have worked with sample code share by you and that contain some undefined variables. Would you please share SSCCE code that you are using for this , so that we may try to reproduce and investigate it in our environment.

Hello Adnan, thanks a lot for your reply.

I have now prepared a complete maven project. After importing the project in eclipse and after installing the PS_Printer (as described earlier) and putting the .pdf file into C:\temp folder and adding your license file into the project main folder, you should be able to run the unit test in class AsposeTicket211831.

211831.zip (2.7 MB)

Thanks a lot for your support
Anne

@wroet001

We are checking it and will get back to you shortly.

Hi all, could you please revert the private flag so that my colleague would have access to that ticket?
Thanks a lot
Anne

@wroet001,

I have made this thread public and we are working on this issue. We will share feedback with you soon.

Hello Ahmad and Ali, are there any news on the issue?
Thanks a lot
Anne

@wroet001,

Thanks for contacting support.

I have observed your comments and created investigation ticket with ID PDFJAVA-39408 in our issue tracking system to investigate and resolve this issue as soon possible.