We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Convert PDF doesn't respect PDF A-1B

Hi support,

When I’ve began with Aspose, I’ve tried to convert any PDF to PDF A 1B and it worked fine.
After that, I’ve extend my converter to add some options (compress images, change font if necessary, etc…)

Currently, it’s working correctly but some PDF (created by many applications like pdf creator, open office, etc…) are not converting correctly.

Original file is stylePolice.pdf
Convert file is destination.pdf

Please find below the code and attached to this post error created by convert method:

this.document.convert(streamLogger,PdfFormat.PDF_A_1B, ConvertErrorAction.Delete);
this.document.validate(streamLogger, PdfFormat.PDF_A_1B);
logger.debug(new String(streamLogger.toString()));


I’m working on Linux with the True Type font installed (mstcorefonts). If you need more information, tell it :slight_smile:


Regards,

Florian



Hi Florian,


Thanks for using our API’s.

I have tested the scenario and have managed to reproduce same problem. For the sake of correction, I have logged it as PDFJAVA-36002 in our issue tracking system. We will further look into the details of this problem and will keep you posted on the status of correction. Please be patient and spare us little time. We are sorry for this inconvenience.

The issues you have found earlier (filed as PDFJAVA-36002) have been fixed in Aspose.Pdf for Java 16.12.0.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.
(3)