We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Convert PPTX file to an image- but I got an gray image

Hi,


I got a problem when I was trying to convert ptt file to image file(jpg)

Here is my code:

Presentation pre = new Presentation(new FileInputStream(new File(“data/Ppttest.pptx”)));
ISlide slide = pre.getSlides().get_Item(0);
BufferedImage tbImage = slide.getThumbnail(1f, 1f);
UUID uuid = UUID.randomUUID();
File tbFile = new File(“tmp/”+uuid.toString()+".jpg");
if(!tbFile.getParentFile().exists())
tbFile.getParentFile().mkdir();
ImageIO.write(tbImage, “JPEG”, tbFile);


And I got a Black-White(Gray?) jpg image.

Is there any way to fix this?

Hi,

Thank you for sharing the sample file.

I am able to reproduce your mentioned issue after an initial test. Your issue has been registered in our issue tracking system with issue id: SLIDESJAVA-34575. You will be notified via this forum thread once the issue gets resolved.

Thanks & Regards,

Hi there

Is this fix have an ETA?

Hi,

I have discussed the issue with our product team and like to share that we have scheduled the issue for week 18/2017. We will be able to share further updates with you in this regard as soon as the investigation will be completed by our product team.

Many Thanks,

The issues you have found earlier (filed as SLIDESJAVA-34575) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

Hello

I have a similar issue with the attached pptx where the getThumbnail method gives me a b&w image also even with aspose-slides-17.4-jdk16.jar

(Also with aspose-slides-17.4-jdk16.jar, I have square for the japanese chars whereas with 15.1 jar it was ok, I suppose this one is a change between these 2 versions on fonts management ?)
Attached the thumbnails for 15.1 and 17.4

Sebastien

Hi Sebastien,

Thanks for inquiring Aspose.Slides.

I have worked with your presentation using Aspose.Slides for Java 17.5 in Windows 7 with JDK 1.7 on my end. I have not been able to observe issue on my end when generating thumbnail. I suggest you to please make sure if fonts used in your presentation are available on your machine as well. Please share, if I may help you further in this regard.

Many Thanks,

I agree you do not have the fonts problem (and I think indeed I had a pb with fonts on my instance) but you still have the black&white problem for slide_0

Hi Sebastien,

I have worked with the presentation file shared by you and have been able to observe the issue. An issue with ID SLIDEJAVA-36428 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be fixed.

We are sorry for your inconvenience,