We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Convert RTF to HTML & Manage Java Lang IllegalStateException: Expected Pad Cells Only Problem

I’m getting many of the following errors while converting RTF documents into HTML. We’re using version version 19.8 for Java.

java.lang.IllegalStateException: Expected pad cells only.
	at com.aspose.words.zzZHN.zzK(Unknown Source)
	at com.aspose.words.zzZHT.visitRowEnd(Unknown Source)
	at com.aspose.words.Row.zzY(Unknown Source)
	at com.aspose.words.CompositeNode.acceptCore(Unknown Source)
	at com.aspose.words.Row.accept(Unknown Source)
	at com.aspose.words.CompositeNode.acceptChildren(Unknown Source)
	at com.aspose.words.CompositeNode.acceptCore(Unknown Source)
	at com.aspose.words.Table.accept(Unknown Source)
	at com.aspose.words.CompositeNode.acceptChildren(Unknown Source)
	at com.aspose.words.CompositeNode.acceptCore(Unknown Source)
	at com.aspose.words.Body.accept(Unknown Source)
	at com.aspose.words.zzZW7.zzYO(Unknown Source)
	at com.aspose.words.zzZW7.zzZ(Unknown Source)
	at com.aspose.words.zzZW7.zzY(Unknown Source)
	at com.aspose.words.zzZW7.zzZr1(Unknown Source)
	at com.aspose.words.zzZW7.zzZGl(Unknown Source)
	at com.aspose.words.zzZW7.zzZrp(Unknown Source)
	at com.aspose.words.zzZRA.zzZ(Unknown Source)
	at com.aspose.words.zzZFK.zzZ(Unknown Source)
	at com.aspose.words.Document.zzZ(Unknown Source)
	at com.aspose.words.Document.zzZ(Unknown Source)
	at com.aspose.words.Document.zzZ(Unknown Source)
	at com.aspose.words.Document.save(Unknown Source)
	at com.idexx.nlp.parsers.RTFConvertToHtml.convert(RTFConvertToHtml.java:49)
	at com.idexx.nlp.parsers.DefaultParser.parseRTF(DefaultParser.java:46)
	at com.idexx.nlp.parsers.DefaultParser.parseInputStream(DefaultParser.java:97)
	at com.idexx.nlp.parsers.DefaultParser.parseDocument(DefaultParser.java:32)
	at com.idexx.nlp.pipelines.MedicalNoteParsingPipelineDebugger.run(MedicalNoteParsingPipelineDebugger.java:53)
	at com.idexx.nlp.parsers.MedicalNoteParsingPipelineTests.testPipeline(MedicalNoteParsingPipelineTests.java:19)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:498)
	at org.testng.internal.MethodInvocationHelper.invokeMethod(MethodInvocationHelper.java:108)
	at org.testng.internal.Invoker.invokeMethod(Invoker.java:661)
	at org.testng.internal.Invoker.invokeTestMethod(Invoker.java:869)
	at org.testng.internal.Invoker.invokeTestMethods(Invoker.java:1193)
	at org.testng.internal.TestMethodWorker.invokeTestMethods(TestMethodWorker.java:126)
	at org.testng.internal.TestMethodWorker.run(TestMethodWorker.java:109)
	at org.testng.TestRunner.privateRun(TestRunner.java:744)
	at org.testng.TestRunner.run(TestRunner.java:602)
	at org.testng.SuiteRunner.runTest(SuiteRunner.java:380)
	at org.testng.SuiteRunner.runSequentially(SuiteRunner.java:375)
	at org.testng.SuiteRunner.privateRun(SuiteRunner.java:340)
	at org.testng.SuiteRunner.run(SuiteRunner.java:289)
	at org.testng.SuiteRunnerWorker.runSuite(SuiteRunnerWorker.java:52)
	at org.testng.SuiteRunnerWorker.run(SuiteRunnerWorker.java:86)
	at org.testng.TestNG.runSuitesSequentially(TestNG.java:1301)
	at org.testng.TestNG.runSuitesLocally(TestNG.java:1226)
	at org.testng.TestNG.runSuites(TestNG.java:1144)
	at org.testng.TestNG.run(TestNG.java:1115)
	at com.intellij.rt.testng.IDEARemoteTestNG.run(IDEARemoteTestNG.java:66)
	at com.intellij.rt.testng.RemoteTestNGStarter.main(RemoteTestNGStarter.java:110)

@dkincaid,

Have you also tried the latest version of Aspose.Words for Java i.e. 20.1 on your end? In case the problem still remains, please ZIP and upload your input RTF Word document and piece of source code here for testing. We will then investigate the issue on our end and provide you more information.

I tried version 20.1 and I still get the same error. Attached is one of the RTF files that throws the error. I also included the function I’m using to do the conversion. The exception happens at line 23 of this code.

It is a huge problem for us since it is happening with so many documents.

Thank you for taking a look.

  • Dave

aspose-error.zip (5.0 KB)

@dkincaid,

We tested the scenario and have managed to reproduce the same problem on our end. For the sake of correction, we have logged this problem in our issue tracking system. The ID of this issue is WORDSNET-19805. We will further look into the details of this problem and will keep you updated on the status of correction. We apologize for your inconvenience.

1 Like

Is there anywhere I can look to see what the status of this defect is and when it will be fixed?

@dkincaid,

I am afraid, your issue (WORDSNET-19805) is currently ‘pending for analysis’ and is in the queue. We will inform you via this thread as soon as this issue will be resolved in future. We apologize for your inconvenience.

Unfortunately, there is no direct way that you can use to track issues by yourself. But, you are welcome to ask your issue status via forum threads. We will verify the status from our internal issue tracking system and then reply you back.

Could you provide an update on this issue? When do you expect it will be fixed?

Thanks,

Dave

@dkincaid,

I am afraid, your issue is currently pending for analysis and is in the queue. There are no estimates available at the moment. Once the analysis of this issue is completed and the root cause is determined, we may then be able to calculate and share the ETA of this issue with you. We apologize for your inconvenience.

The issues you have found earlier (filed as WORDSNET-19805) have been fixed in this Aspose.Words for .NET 20.4 update and this Aspose.Words for Java 20.4 update.