We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Convert Slides(pptx) to svg with image/text Lost

Hi, I was trying to conver slides to svg, and I found that there was some text and image disappeared.


Here is my code:
Presentation origPres = new Presentation("…/…/page.pptx");
ISlide slide = origPres.Slides[0];
MemoryStream ms = new MemoryStream();
slide.WriteAsSvg(ms);
System.IO.File.WriteAllBytes("…/…/output.svg", ms.ToArray());

There are pptx file and screenshot of the result svg file in the attachment,
Please help me fix this problem, Thank you :slight_smile:

Hi,


I have worked with the presentation file shared by you and have been able to observe the issue specified. An issue with ID SLIDESNET-36077 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

Many Thanks,

Hi There


I check this issue again, and found there are still something missing in the result with 16.10.0 in Linux environment.

Here is my code for test:
Presentation pre = new Presentation(“7MB.ppt”);

String dirName = UUID.randomUUID().toString();
File file = new File("" + dirName);
file.mkdirs();

for (int i = 0; i < pre.getSlides().size(); i++) {

pre.getSlides()
.get_Item(i)
.writeAsSvg(
new FileOutputStream(""
+ dirName + “/” + (i + 1) + “.svg”));

}

This issue happens in page #19.
I have upload a comparison image, the PowerPoint file, and the result.
Please check it and analyze this issue again, thank you


Craig

Hi Craig,


I have worked with presentation file shared by you using Aspose.Slides 16.10.0 and unable to reproduce issue. I have shared my generated output with you for your kind reference. If there is still an issue then please share environment details java version details so that we can investigate issue in details. Please see attachments.

Best Regards,
Hi Adnan.Ahmad

I used following command retrieving system information.

uname -a
Linux d1ars04.novalocal 3.10.0-327.18.2.el7.x86_64 #1 SMP Thu May 12 11:03:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/*-release
CentOS Linux release 7.2.1511 (Core)
NAME="CentOS Linux"
VERSION="7 (Core)"
ID="centos"
ID_LIKE="rhel fedora"
VERSION_ID="7"
PRETTY_NAME="CentOS Linux 7 (Core)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:centos:centos:7"
HOME_URL="https://www.centos.org/"
BUG_REPORT_URL="https://bugs.centos.org/"

CENTOS_MANTISBT_PROJECT="CentOS-7"
CENTOS_MANTISBT_PROJECT_VERSION="7"
REDHAT_SUPPORT_PRODUCT="centos"
REDHAT_SUPPORT_PRODUCT_VERSION="7"

CentOS Linux release 7.2.1511 (Core)
CentOS Linux release 7.2.1511 (Core)

java -version
java version "1.7.0_101"
OpenJDK Runtime Environment (rhel-2.6.6.1.el7_2-x86_64 u101-b00)
OpenJDK 64-Bit Server VM (build 24.95-b01, mixed mode)


Craig

Hi Craig,


I have observed your comments. I like to share that the issue is going to be resolved tentatively in Aspose.Slides 16.11.0. We will share notification with you once issue will be fixed.

We are sorry for your inconvenience,

Hi Adnan.Ahmad


Thanks for your information.
It seems that this issue is not yet be fixed in 16.11.0.
We will wait for the update for this issue, and thanks for your help :slight_smile:

Update:
Comparison image and result files.

Please check the attachment


Craig

Hi Craig,


You are very welcome.

Best Regards,

The issues you have found earlier (filed as SLIDESNET-36077) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.