Free Support Forum - aspose.com

Convertering slide with image to PDF


#1

We have a powerpoint file with an image that disappears when converting it to pdf

.92346c41-c604-4c98-b568-fc7ca7e2ef32.pdf (34.6 KB)
Archive.zip (1.8 MB)


#2

@peterkondrup,

I have worked with source file shared by you using Aspose.Slides for .NET 19.2 and unable to observe any issue. Can you please try to use Aspose.Slides latest version on your end and if there is still an issue than please share environment details along with sample code so that we may further investigate to help you out. I have also shared my generated result with you for your kind reference.PowerPointWithPicture.pdf (1.8 MB)


#3

Still doesn’t work on latests version. (We were on 19.1).

We are running i docker containers on k8s. (Dotnet core 2.2)

The code.

 public Task<ConverterResult> ConvertDocumentAsync(byte[] inputfile)
    {                                   
        var result = new ConverterResult();

        var loadOptions = new LoadOptions {InterruptionToken = _token.InterruptionToken.Token};
        result.convertedFile = ConvertPowerPointDocument(inputfile, loadOptions);                                                                      

        return Task.FromResult(result);
    }
    
    
    private byte[] ConvertPowerPointDocument(byte[] inputFile, LoadOptions loadOptions)
    {
        var document = new Presentation(new MemoryStream(inputFile), loadOptions);            
        
        foreach (var entry in FontSubstitutionOptions.FontStyleSubstitutionMap)
        {
            // The font-subtitution rules seem to be related to the document-obj
            // for powerpoint-presentations (rather than being set globally)
            document.FontsManager.FontSubstRuleList.Add(
                new FontSubstRule(
                    new FontData(entry.Key),
                    new FontData(entry.Value)
                )
            );
        }

        using (var outputStream = new MemoryStream())
        {
            document.Save(outputStream, SaveFormat.Pdf);
            return outputStream.ToArray();               
        }
    }

#4

@peterkondrup,

As requested earlier we were unable to obtain issue using Aspose.Slides for .NET 19.2 and suggested you to try the same on your end. In case there is still an issue please share with us.


#5

We are using 19.2 and are still experienceing the issue. Have you tried running it on a linux docker container?


#6

@peterkondrup,

Thank you for sharing the information. We have created an issue with ID SLIDESNET-40984 in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.