We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Curved lines does not seem to work

When I change line 25 in example ‘Working_Shapes.SetConnectorAppearance’ from


shape.SetConnectorsType(ConnectorsTypeValue.StraightLines);

to

shape.SetConnectorsType(ConnectorsTypeValue.CurvedLines);

The line does not become curved and makes a strange, straight angle down (not pointing at the target anymore).

The connector turns into a curved line when I open the diagram in Visio 2013 and drag one of the connecting shapes.

I’ve attached the example output.

Hi Sil,


Thank you for contacting support. We managed to replicate the problem of incorrect display of the connector line. It has been logged under the ticket ID DIAGRAMNET-51249 in our bug tracking system. We have linked your post to this ticket and will keep you informed regarding any available updates. We are sorry for the inconvenience caused.

Hi Sil,


Thank you for being patient. The ticket ID DIAGRAMNET-51249 has been resolved. If there is no issue in the quality assurance phase, then this fix will be included in the next version 17.6 of Aspose.Diagram for .NET API. We will notify you in this thread as soon as the new release is published.

Hi Sil,

Thank you for being patient. In reference to the ticket ID DIAGRAMNET-51249, please download and try this latest Hotfix version: Aspose.Diagram for .NET 17.5.1. Please also let us know how that goes on your side.

Hi,

I have the same problem. I am using ASPOSE Java 17.6.0.

CurvedConnectorBug.zip (77.9 KB)

@dragos.petrescu,
We managed to replicate the problem of incorrect display of the connecting line. It has been logged under the ticket ID DIAGRAMJAVA-50532 in our bug tracking system. We have linked your post to this ticket and will keep you informed regarding any available updates. We are sorry for the inconvenience caused.

Best Regards,
Imran Rafique