We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Data Population Issue GridWeb

Hi,

Thank you for quick response. I am running into another problem. I have populated data in row 6 and 7 of column 1 (0-based index). But when I render this excel on gridweb it displays those data in row 1 and 2 (0-based index). I am attaching the excel sheet. Could you please let me know how can i fix this?

Hi,


Thanks for the template file.

I have tested your scenario/ case using Aspose.Cells.GridWeb v8.1.0.2xxx (latest version of GridWeb packaged in Aspose.Cells for .NET v8.1.0 - you may download and try it from Downloads module) with your template file, it works just fine. I am using the following sample code to load the file to GridWeb matrix, see the screen shot for your reference.
e.g
Sample code:

string filePath = @“e:\test2\Dev-Test+Default+Sheet1.xlsx”;

GridWeb1.WebWorksheets.ImportExcelFile(filePath);


Thank you.

Hi Jagriti,


First of all, we have split the existing thread to create a new one on your behalf. Reason being, it’s recommended to create a new thread for each distinct type of inquiry/problem.

For your recently shared scenario, we would suggest you to please give the latest version of Aspose.Cells.GridWeb 2.7.22.2000 (packaged in Aspose.Cells for .NET 8.1.0) a try on your end. Hopefully the latest version will fix the presented scenario. In case the problem persists, please provide us a sample application replicating the issue. Upon reviewing the sample project we can suggest you a solution or in case the problem is on the part of Aspose.Cells.GridWeb component, we can move forward to fix the problem by logging an appropriate ticket.

Thank you for your cooperation.

Hi,

I am using Aspose.Cells.Gridweb version 8.0.1.2000. My application is rendering attached excel sheet on gridweb. But on gridweb it does not display the data at the same cell as it displays when I open the excel sheet in excel application. Attached excel sheet has 3 worksheets. Worksheet "TESTDATA" renders at same cell (H16) as excel application. Woksheet "FORMULAS" renders data "04/28/2014" at I14 on excel but on gridweb it renders at cell I11. Similarly worksheet "FILTER" renders data "Yes" at cell "D14" on excel application but on gridweb it renders at cell "D13".

I am attaching screenshot of Gridweb output for all 3 tabs and excel sheet. Could you please help me to solve the problem so that Gridweb can renders the excel sheet same as excel application.

Thanks in advance

Jagriti

Hi Jagriti,


Thank you for writing back.

By looking at the snapshots, we believe you are currently using an old version of Aspose.Cells.GridWeb assembly. As suggested earlier, please upgrade your application to use the latest build that is packaged in Aspose.Cells for .NET 8.1.0.

Please note, we have again tested the scenario on our end while using the Aspose.Cells.GridWeb 8.1.0.2000, and we are not able to see the problem as mentioned in this thread. Please review the attached snapshots for your kind reference.