Free Support Forum - aspose.com

Default style

We use Telerik as docx (Rich Text) editor for all user-inputted data.<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

we save this binary in the database and with mailmerge we insert this in documents. (bytestream)

If we open this document with aspose and just save it again, our default style changes and so is the style of the text.

So if we open it with word it shows the text with the style “Standaard” with the font Verdana.

If we open and save it with aspose it changes to a new default style “Normal” with the font Portable User Interface.

Thanks,

Kris

Hi Kris,


Thanks for your inquiry.

Aspose.Words requires fonts to be present on the machine for embedding and use during rendering. If fonts are not found then they are substituted with the next closest font.

Please see the following article for how Aspose.Words handles fonts when rendering: http://www.aspose.com/docs/display/wordsnet/How+Aspose.Words+Uses+True+Type+Fonts

Note that you can supply your own fonts by specifying the folder where the fonts are contained. You can set the default font used during rendering by setting FontSettings.DefaultFontName:

FontSettings.DefaultFontName = “Arial Unicode MS”;


I’m afraid there hasn’t been much discussion from customers on how they are dealing with licensed fonts. If you find any revalant information then please feel free to share it through a comment on our confluence documentation pages here: http://www.aspose.com/docs/display/wordsnet/How+Aspose.Words+Uses+True+Type+Fonts

I hope, this will help. In case of any ambiguity, please let me know.

Hi,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

The font in the document is Verdana and it is present on the machine, yet the font changes from Verdana in Portable User Interface just by opening and saving in Aspose.

If the name of the default font isn’t changed to “Standaard” it also works, so it looks like Aspose handles default fonts different then Word.

Grtz,

Kris

Hi Kris,


Thanks for the additional information. While using latest Aspose.Words 11.3.0. I managed to reproduce this problem on my side. I have logged your issue as WORDSNET-6269 into our bug tracking system. Your request has also been linked to the appropriate issue. Once we sort it out, we will let you know.

In addition, we can reproduce the problem with MS Office 2010 only. As workaround you can manually check “Embed fonts in the file” like File–> options --> Save --> embed fonts in the file (Checkbox) .

W’re sorry for the inconvenience.

Any update on this issue ?

Thanks,

Kris

Hi
Kris,


Thanks for your inquiry. Unfortunately, this issue is still unresolved. Currently, it is pending for analysis and is in the queue. We will inform you via this forum thread as soon as it’s resolved.

Best Regards,

The issues you have found earlier (filed as WORDSNET-6269) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

The issues you have found earlier (filed as ) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by MuzammilKhan