We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Digital grouping symbol issue

Hi,
We are using Aspose.cells version 17.9, and facing an issue while converting .xls document to PDF. The issue is with digital grouping symbol in numbers. We have set the Format in Region settings to Spanish (Chile), in which the digital grouping symbol is “.”(Dot) instead of “,”(Comma), But after conversion to PDF, the document does not show the correct separator and it display “,” instead of “.” whereas in Microsoft.Excel and while converting document to PDF format through Microsoft.Excel it displays the digital grouping symbol correctly according to the region settings.
I have also produced this issue with Aspose.cells version 19.2

@Wahaj_Khan,

Thanks for sharing some details.

Could you share the template Excel file and output PDF file (via Aspose.Cells) so we could evaluate your issue precisely to figure it out soon. Also, paste your sample code (runnable) that you are using. By the way, you may try to set NumberGroupSeparator accordingly, see the example code segment for French locale and write/update it accordingly (before rendering to PDF file format) for your specified regional settings if it makes any difference:
e.g
Sample code:

CultureInfo ci = new CultureInfo(“fr-FR”);
ci.NumberFormat.NumberGroupSeparator = " ";
wb.Settings.CultureInfo = ci;

@Amjad_Sahi
I have attached the document along with the screen shots regarding the issue for better understanding.
Also find the working code snippet below:

            Workbook WrkBook = new Workbook(InputFileName);
            Aspose.Cells.PdfSaveOptions PdfSaveOptions = new Aspose.Cells.PdfSaveOptions();
            PdfSaveOptions.Compliance = Aspose.Cells.Rendering.PdfCompliance.PdfA1b;

            using (var CompressedFileStream = new FileStream(tempfile, FileMode.OpenOrCreate, 
            FileAccess.ReadWrite, FileShare.None))
            {
                WrkBook.Save(CompressedFileStream, PdfSaveOptions);
                CompressedFileStream.Seek(0, System.IO.SeekOrigin.Begin);
                OutputFileBytes = new byte[CompressedFileStream.Length];
                CompressedFileStream.Read(OutputFileBytes, 0, (int)CompressedFileStream.Length);
            }
            // Convert into PDF/A-2A
            Aspose.Pdf.Document PdfDocument = new Aspose.Pdf.Document(new 
            MemoryStream(OutputFileBytes));
            using (var CompressedFileStream = new FileStream(tempfile, FileMode.OpenOrCreate, 
               FileAccess.ReadWrite, FileShare.None))
            {
                PdfDocument.Convert(new MemoryStream(), PdfFormat.PDF_A_2A, 
                ConvertErrorAction.None);
                PdfDocument.Save(CompressedFileStream);
                OutputFileBytes = new byte[CompressedFileStream.Length];
                CompressedFileStream.Seek(0, System.IO.SeekOrigin.Begin);
                CompressedFileStream.Read(OutputFileBytes, 0, (int)CompressedFileStream.Length);
            }

Digital grouping symbol issue.zip (128.3 KB)

@Wahaj_Khan,

Thanks for the template file and sample code segment.

I tested your scenario/ case using our latest version/fix, i.e., Aspose.Cells for .NET v19.4 (please try it if you are not already using it). I used simplest lines of code (by excluding Aspose.PDF API) and simply converted your file to PDF file format in compliance with PDFA1b. Please note, I first set my OS regional settings to Spanish (Chile) as per your screenshots and then used/run the code to produce the output PDF file (attached). I could not spot any issue.
e.g
Sample code:

Workbook WrkBook = new Workbook("e:\\test2\\Orden de Compra evidencia  (2).xlsx");
            Aspose.Cells.PdfSaveOptions PdfSaveOptions = new Aspose.Cells.PdfSaveOptions();
            PdfSaveOptions.Compliance = Aspose.Cells.Rendering.PdfCompliance.PdfA1b;

            WrkBook.Save("e:\\test2\\out1.pdf", PdfSaveOptions);   

Please open the output file (attached) ad let us know if you find any issue. If so, kindly give us more details, so we could evaluate your issue further.
files1.zip (139.4 KB)