We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Disabling context menu

Hi,

I want to hide the gridweb context menu.
I modified the postfix file to lang_pers.js, where I commented out all the menu item:

// context menu items text
// MenuItemCopy :"Copy",
...
// MenuItemFilterAll :"(ALL)",

Everything is fine, except that when I right click on the grid.
The context menu are displayed but marked as undefined.
Also they are still effective (even if marked undefined).

What should I had to completly remove the context menu?
Thanks for your help.
(gridweb 1.9.3.0)

Hi,

I think you may try to use set the following GridWeb's properties to false to eliminate some context menu options:

EnableClientColumnOperations

EnableClientRowOperations

EnableClientFreeze

EnableClientMergeOperations

EnableClientResizeColumnRow

EnableStyleDialogbox

Thank you.