We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Display problem IE7 (columns)

Dear,

I have a display problem when importing an excel worksheet. In IE8, Firefox 10 and Chrome 17 all is displayed well.

However in IE7 (or compatibility mode in IE8), the columns do not show correctly their text. The cell is much higher than normal, and not all text is displayed

Attached is a sample. Note that I do have a license, and that in the real application I set the license. Also, the project is configured to run in IIS, not the builtin server of Visual studio (to allow for the acw client path easily to be set). If you run the default.aspx page in IE8, and then click "compatibility mode" in the browser, you'll see what I mean.

Please advice urgently how to solve this.

Thank you,
Tom

Hi,

Thanks for providing us your project files.

Could you also provide us screenshots showing differences in different browsers? It will help us to sort out the problem quickly.

We have logged your issue in our database. We will look into it and fix the problems.

This issue has been logged as CELLSNET-40412.

Hi,

If you are using IE9/IE8 with IE7 compatibility mode, then please remove the table tag contains GridWeb control. Otherwise, there will be some rendering issues.

There is no table on the form.


<acw:GridWeb ID="grdWeb" runat="server" ShowSaveButton="False" Width="100%" Height="100%" ViewTableStyle-LayoutFixed="Fixed" XhtmlMode="false"
DisplayCellTip="False" EnableAJAX="True" ShowBottomBar="False"
ShowContextMenu="False" ShowDefaultGridLine="False" ShowHeaderBar="False"
ShowSubmitButton="False" ShowUndoButton="False">



The screen shots have been attached.

Thanks

Hi,

Thanks for your screenshots, it will help us sort out the problems.

Please also try setting the XhtmlMode=“true” and see the results.

I already tried that. That’s actually worse. Then it doesn’t display well in any browser.

Hi,

We did not support this feature, we suggest you to draw one line into several cells when the line exceed the length of the column

For example:

“Company cars: Benefit in kind” , split the line to “D” “E” “F” “G” “H” “I” columns, then the effect should be what you expect.

Hi,


For the bug, if you could set XhtmlMode="true" then the data “Company cars: Benefit in kind” will be hidden when the line exceeds the length of the column. If you set XhtmlMode=”false” then the data will be shown well in IE8,IE9, but due to effects for IE7, it does not work well though.