Free Support Forum - aspose.com

Distribution

Previous version of aspose.total (3.3.x.x) allowed us to place .net assemblies in folder with .exe when our own assembly referencing the aspose.cells resided in one folder level below.

for Client machines distribution, we just distribute the runtime .cells, .words, and .lic file with file copy.

We upgraded to 4.4.x.x. Our application can't find the new aspose assemblies.

Has anything changed regarding target computer installation of the software with version 4.4.x.x

Thanks,

Jon Sklut


This message was posted using Page2Forum from Aspose.Cells - File Format Components - Documentation

Hi,

Well, you just need to delete the previous reference in your project, copy the new Aspose.Cells.dll (fix) to your specified folder, Now, Add Reference to the component in your project and use it.

Thank you.

Thanks for your reply.

Adding the new components and recompiling is not an issue. Just at runtine on a target machine. Here is how we currently deploy

Folder A has Executable and apose files (incl. .lic)

Subfolder A.1 (under folder A) has referenced our own .net application assemblies to the executable. One of those assemblies references the aspose dlls in the folder above.

This worked without issue with ver 3.3.x.x, but not 4.4.x.x

I tried moving the 4.4.x.x dlls to Subfolder A.1 with the assembly the wrote that references them with no luck.

Is there published deployment instructions for version 4.4.x.x. to follow?

thanks,

Jon

What's the exact error message?

Please rebuild all your application with the new dll. We don't change anything with the deployment.

Aspose.Cells.dll is a strong named assembly so a rebuild is a must for the upgrade.