Free Support Forum - aspose.com

Document.MailMerge.Execute() produces one extra symbol

Hi,

I use Document.MailMerge.Execute to merge application data into a Word document.
When the application data contains symbols, like bullets, Aspose.Word produces one extra symbol.
This occurs only when the number of symbols in the application data is three or more.

Is this some unexpected Word feature? Perhaps autocompletion? I have switched these options off, but to no avail.

The attachment is a minimal version of my code, to demonstrate the problem.
The corresponding Word document has only the one mergefield.

Hi Wilhelm,


Thanks for your inquiry.

While using the latest version of Aspose.Words i.e. 10.6.0, I was unable to reproduce this issue on my side. I would suggest you to visit the following link for downloading and using the latest version:

http://www.aspose.com/community/files/51/.net-components/aspose.words-for-.net/default.aspx

In case, if this issue is still occurring with the latest version could you please attach your input document for testing. I will investigate the problem on my side and provide you more information.

Best Regards,
<!–[if gte mso 10]> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:10.0pt; font-family:"Times New Roman","serif";}

<![endif]–>

Hi,

I also tried but couldn’t generate issue. It seems that you just need to turn off “Show Paragraph Marks” of MS Word.

Thanks

Thanks Awais for the quick response.

Indeed, the latest version solves this problem. I was using 10.1.
Had no idea you release a new verion every month..

Hello

It is perfect, that you already found the solution. If you need more assistance, We will be glad to help you.

Best regards,