We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Does Aspose.BarCode for JasperReports supports JDK 1.4?

Hi,


Is it possible to use Aspose.BarCode for JasperReports with JDK 1.4? I got the following error messages during compilation.

"class file has wrong version 49.0, should be 48.0
please remove or make sure it appears in the correct subdirectory of the classpath
import com.aspose.barcode.jr.BarCodeAttributes…"

This message was posted using Email2Forum by saqib.razzaq.

Hi Kim,


Thank you for inquiry.

The current version requires at least JDK 1.5 or above, as mentioned at http://www.aspose.com/documentation/jasperreports-exporters/aspose.barcode-for-jasperreports/system-requirements.html page.

Regarding JDK 1.4 support, I will consult with the developers to find out if it is feasible to make another jar file for JDK 1.4. I will get back to you with the feedback soon. Sorry for the inconvenience.