We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Does Aspose.Pdf for Java support PDF 1.6 or above?

I was wondering if it supports up to v1.7.

Hi Lucian,


Thanks for contacting support.

I am pleased to share that Aspose.Pdf for Java supports all PDF versions including v1.3, v1.4, v1.5, v1.6 and v1.7. Please try using our API’s and in case you encounter any issue or you have any further query, please feel free to contact.

I tried it and it doesn’t seem to support PDF1.6. PDFs were printed out as blank pages. PDFs with v1.5 were printed as expected. Can you please confirm? I’m talking about the JAVA version.

Hi Lucian,


Thanks for your feedback. We have tested the scenario and unable to replicate the reported issue. We will appreciate if you please share your sample code and source document, so we will look into the issue and will provide you more information accordingly.

We are sorry for the inconvenience caused.

Best Regards,
Please find attached the sample PDF with the source code below. It's printed as blank pages.

PdfViewer pdf = new PdfViewer();
pdf.bindPdf("d:/pdf_implementation.pdf");
pdf.setPrintPageDialog(false);
pdf.setAutoResize(true);
pdf.setAutoRotate(true);
PrinterJob printerJob = getPrintService("myprinter");
pdf.setPrinterJobName(printerJob.getJobName());
pdf.printDocument();
pdf.close();




Hi Lucian,


Thanks for sharing the resource file.

I have tried printing the document with Aspose.Pdf for Java 4.6.0 and I am afraid I am getting OurOfMemoryError. For the sake of correction, I have logged this problem
as PDFNEWJAVA-34060 in our issue tracking system.
However, can you please share the version information which you are using to print the document.

We will further look into the details of this problem and will keep you updated on the status of correction. Please be patient and spare us little time. We are sorry for this inconvenience.

Furthermore, please note that Aspose.Pdf for Java also supports the feature to upgrade or downgrade PDF file version. You may consider using the following code snippet to change file version to v1.5.

[Java]

// load source PDF file<o:p></o:p>

com.aspose.pdf.Document document = new com.aspose.pdf.Document("c:/pdftest/pdf_implementation.pdf");

// convert file format to v1.5

document.convert("c:/pdftest/ConversionLog.txt", com.aspose.pdf.PdfFormat.v_1_5, com.aspose.pdf.ConvertErrorAction.Delete);

// save resultant PDF file

document.save(“c:/pdftest/VersionUpdated.pdf”);

V4.3 I think. The library doesn’t seem to support PDF 1.6. I tried it with a different file, same result. I tried another commercial library and it did print it as expected.

Hi Lucian,


I have also tested the scenario using Aspose.Pdf for Java 4.3.0 and I am still getting OutOfMemoryError. The development team will further look into this matter and will keep you posted on the status of correction. Please be patient and spare us little time.

However, did you try downgrading the PDF file from v1.6. to v.1.5 and tried printing the document

Hi Nayyer,


I haven’t tried it as downgrading is not an option from system point of view unfortunately. It would be much appreciated if it can be fixed asap.


Hi Lucian,


The problem has been logged in issue tracking system and the team will try investigating and resolving it based on its schedule. As soon as we have some further updates, we would be more than happy to update you with the status of correction within this forum thread.

Is there a target release in which this issue will be fixed?

Hi Lucian,


As we recently have been able to notice this
issue, so development team requires little time to investigate and figure out
the reasons of this problem.
Furthermore, please note that you
have reported issue under normal/free support forum and as a normal rule
of practice, issues are resolved in first come and first serve basis; but the
problems logged/reported under Enterprise or Priority support model, have high
precedence in terms of resolution, as compare to issues under normal/free
support model.

The issues you have found earlier (filed as PDFNEWJAVA-34060) have been fixed in Aspose.Pdf for Java 11.4.0.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.