We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Does Aspose Slides (Java ver. 1.9.0) supports Power Point 2007?

I am evalivating the Aspose Slides (Java ver.) to upgrade from the 1.7.x version, which we are currently using. In this We are expecting that Aspose will support the latest Power Point version. But with a simple example when I tried to read a (.pptx) file, it given me an exception:


Caused by: java.io.IOException: Invalid header signature; read 1688935826934608, expected -2226271756974174256

Any Idea about the issue please.

Dear Rajeev,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Make sure you are using PresentationEx class not Presentation class for opening a pptx file. In case, you still get an error, then paste your code and attach the presentation, so that we could look into it and fix it.

Hi Shakeel,



Thanks a lot for the quick respose.



I have followed your suggestion, with the following code,



try {



String directoryPath = “D:\test\SB-08-01-2009\pptx\”;

String sourceFile = “15 As-is Process Map.pptx”;



PresentationEx sourcePresentation = new PresentationEx(directoryPath + sourceFile);



SlidesEx sourceSlidesEx = sourcePresentation.getSlides();

SlideEx sourceSlideEx = sourceSlidesEx.get(0);

int intx = sourceSlidesEx.addClone(sourceSlideEx);

sourcePresentation.write(directoryPath + “Modified_” + sourceFile);



} catch (PptException e) {

e.printStackTrace();

} catch (FileNotFoundException e) {

e.printStackTrace();

} catch (Exception e) {

e.printStackTrace();

}





But I am ended up with NullPointerException,


java.lang.NullPointerException

at com.aspose.slides.eA.do(SourceFile:613)

at com.aspose.a.f.f.(SourceFile:18)

at com.aspose.slides.eA.(SourceFile:610)

at com.aspose.slides.am.do(SourceFile:610)

at com.aspose.slides.gy.do(SourceFile:78)

at com.aspose.slides.ParagraphEx.if(SourceFile:149)

at com.aspose.slides.ParagraphsEx.if(SourceFile:39)

at com.aspose.slides.TextFrameEx.do(SourceFile:242)

at com.aspose.slides.TextFrameEx.for(SourceFile:164)

at com.aspose.slides.ShapeEx.const(SourceFile:1195)

at com.aspose.slides.ShapesEx.do(SourceFile:1300)

at com.aspose.slides.GroupShapeEx.const(SourceFile:355)

at com.aspose.slides.BaseSlideEx.do(SourceFile:1120)

at com.aspose.slides.SlideEx.do(SourceFile:1467)

at com.aspose.slides.PresentationEx.if(SourceFile:1119)

at com.aspose.slides.SlidesEx.if(SourceFile:60)

at com.aspose.slides.SlidesEx.addClone(SourceFile:42)



I have attached here the ppt that I have used for the test. Am I missing something?


Dear Rajeev,

The following link contains a correct code for cloning pptx slides. It is in C#

http://www.aspose.com/community/files/51/file-format-components/aspose.slides/entry140061.aspx

But when I tried it in JAVA after converting it, it throws NullPointerException; so it is a bug and needs to be fixed.