We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Does your Pdf.Kit support hyperlinks and bookmarks?

I am evaluating your product for basic viewing and printing needs.  I ran your viewer example and noticed that it does not enable any hyperlinks and bookmarks.  Are these supported but not enabled?<br><br>I need good hyperlinking ability both within documents and between them.  I also desire to be able to programatically goto bookmark/named destinations.  Does your product support both of  these operations?<br><br>-dh <br>

Hi,

Thank you for considering Aspose.

The Pdf viewer in Aspose.Pdf.Kit does not support hyperlink and bookmark and we can't support them in short time. Sorry for the inconvenience.

Hi,

Is this Option available now? (Pdf.Kit support to hyperlinks and bookmarks)

Thanks,

Venkat

Hello Venkat,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I am pleased to inform you that Hyperlink and Bookmarks are now supported in Aspose.Pdf.Kit.

For information on adding links, please visit http://www.aspose.com/documentation/file-format-components/aspose.pdf.kit-for-.net-and-java/create-links.html

For more information on changing link information please visit LinkInfo

For information on adding Bookmarks please visit http://www.aspose.com/documentation/file-format-components/aspose.pdf.kit-for-.net-and-java/create-bookmarks-new.html and BookMark

PdfContentEditor is a class that supports these features, for more information please visit PdfContentEditor

If you still have any query, please feel free to share.

Hi,

Our issue is adding text as watermark into existing PDF removes all existing hyperlink in the PDF.

pdf has got hyperlinks and they are working.... and we need to add some text over them as Watermark... and once you have done that, hyperlinks are not working .

Thanks,

Venkat

Hi Venkat,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

I have tested the scenario and I am unable to reproduce the problem at my end. I have tested the issue using Aspose.Pdf.Kit v3.2.0.0. Please share the resource file, so that we can test the issue using that file, at our end.

Thanks. This issue solved.

Looks like you have fixed this issue in the new version. Please check 5168 in

http://www.aspose.com/community/files/51/file-format-components/aspose.pdf.kit/entry139194.aspx