We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Embedded images not displaying properly when using Mozilla PDF viewer

Good afternoon,

We are converting office documents to be displayed in a java script PDF viewer (the same one that is used by Mozilla).
We convert several types of office documents, the most common being word docs.
When we use the latest version of Aspose Words (v10.8.0.0), to convert these docx files to PDF, embedded images do not convert correctly.
We currently use .Net 4.5 in Visual Studio 2012
This packet contains the following:

IssueText.txt -- This document.
WordDoc.docx -- The original file we are converting.
WordDoc.pdf -- The result of the conversion
Convert.cs -- the snippet of code that we use to call your libraries for the conversion.
Original.png -- Screen shot of the original document viewed in Word
FireFoxPDF.png -- Screen shot of the converted pdf in FireFox
AdobePDF.png -- Screen shot of the converted file in the Adobe Viewer

The documet DOES display properly in the Adobe viewer, but our application precludes us from using the Adobe Viewer.
We must use the open source Java Script Viewer that Mozilla uses.

You may notice that we optionally password protect the document. We have tried this both ways with the same results.
You may notice that we also optionally optimize the document. We have tried this both ways with the same results.
We MUST however, secure the document so that it cannot be printed or saved while being viewed.

I am sure there are some save options or load options that we can set to get around this anomoly. Please let us knowif you need more information, or better yet what we can set to get around this issue.

When we load the document in MS-Word and publish as a PDF, it views correctly in both the Adobe viewer and the Java Script viewer,so we are pretty sure that there must be some setting the MS utilizes that is different from what we are doing in Aspose Words.
However, since we do not have access to their code, we don't know that that is.


Thank you.

Hi Tim,

Thanks for your inquiry.

While using the latest version of Aspose.Words i.e. 13.4.0, I managed to reproduce this issue on my side. I have logged this issue in our bug tracking system. The issue ID is WORDSNET-8244. Your request has also been linked to this issue and you will be notified as soon as it is resolved. Sorry for the inconvenience.

Best regards,

Thanks.

Any update on this issue? - it stands in the way of us rolling out an upgrade to our system. We are changing from read-only xps documents to read-only pdf's but we cannot roll out until this issue is fixed.

Hi Tim,


Thank you for being patient. We discovered that Firefox can’t handle tiling pattern in PDF correctly; I am afraid, there is no workaround available to render this DrawingML image to PDF differently and most likely we will close this issue with ‘Not a Bug’ resolution as it does not seem to be directly related to Aspose.Words. It seems to be a bug in FireFox. If we can help you with anything else, please feel free to ask.

Best regards,

Hi Tim,


It is to update you that our development team has completed the work on the issue (WORDSNET-8244) and has come to a conclusion that this issue and the undesired behaviour you’re observing is actually not a bug in Aspose.Words. So, we’ve closed this issue as ‘Not a Bug’. If we can help you with anything else, please feel free to ask.

Best regards,