We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Embedding a TTF on conversion from word to PDF

Hi there


I have read all the articles about font embeddability but we are still having issues with this and I am not sure what else to do. We have tried a number of TTF and OTF fonts. Of the 4 TTF fonts we tried, we can only get 1 font printing when installed on our servers. If I add the other 3 to my local machine they will all work, but take them off my local machine and they won’t work again. We are using an older version of Aspose.Words as upgrading to the later version caused issues with our funds .Net. Our funds are wanting to buy fonts that they want to use but currently we are unable to get these to work with the font. When we open the document in word all the correct fonts display (the funds can then edit the word document), and then when they close the document it automatically saves as PDF. This does not embed the fonts. Will a later version of Aspose.Words sort this issue out? We are more than happy to upgrade as long as it doesn’t mess our .Net with the funds like it did in the past, but want to ensure that an upgrade would definitely fix the font issue. Strangely though, some of our funds have TTF fonts that they bought a number of years ago and they have not had any issues with the fonts being installed on their servers only. Any advice please? (I am very new to this so apologies if this makes no sense). I have added the fonts we tried to embed.
Hi Shona,

Thanks for your inquiry. Could you please also attach your input Word document and output PDF file showing the undesired behavior here for testing? We will investigate the issue on our end and provide you more information.

Best regards,